summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-06-11 16:14:52 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2016-06-21 21:58:59 +0200
commit8bfa230e9fcdc197f3a9652befbb28e9771533f9 (patch)
treeeba18e00d05aad15b8def55d7dde27accee9e428 /target/linux/lantiq/image
parentecdfbeae85d7ab1eaafbed702778dae7389a58c8 (diff)
downloadmaster-31e0f0ae-8bfa230e9fcdc197f3a9652befbb28e9771533f9.tar.gz
master-31e0f0ae-8bfa230e9fcdc197f3a9652befbb28e9771533f9.tar.bz2
master-31e0f0ae-8bfa230e9fcdc197f3a9652befbb28e9771533f9.zip
lantiq: build fullimage.img for EASY80920NAND
This image format is used by Lantiq's / Intel's UGW version 6.1 to 7.1. These images can be flashed onto a board with the SoC vendor boot loader as a replacement for the vendor firmware. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index ff29b2aa78..e0a28c227f 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -188,6 +188,21 @@ define Build/mkbrnimg
mkbrnimg -s $(SIGNATURE) -m $(MAGIC) -p $(CRC32_POLY) -o $@ $(word 1,$^) $(word 2,$^)
endef
+define Build/fullimage
+ mkimage -A mips -O linux -C lzma -T filesystem -a 0x00 \
+ -e 0x00 -n 'LEDE RootFS' \
+ -d $(word 2,$^) $(word 2,$^).new
+
+ cat $(word 1,$^) $(word 2,$^).new > $@.tmp
+
+ mkimage -A mips -O linux -T multi -a 0x00 -C none \
+ -e 0x00 -n 'OpenWrt fullimage' \
+ -d $@.tmp $@
+
+ rm $(word 2,$^).new
+ rm $@.tmp
+endef
+
# Shared device definition: applies to every defined device
define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
@@ -211,6 +226,12 @@ define Device/lantiqBrnImage
endef
DEVICE_VARS += SIGNATURE MAGIC CRC32_POLY
+define Device/lantiqFullImage
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-offset 4 0
+ IMAGES := sysupgrade.bin fullimage.img
+ IMAGE/fullimage.img := fullimage | check-size $$$$(IMAGE_SIZE)
+endef
+
ifeq ($(SUBTARGET),xway_legacy)
define Device/ARV4520PW
@@ -628,6 +649,7 @@ endef
LEGACY_DEVICES += BTHOMEHUBV5A
define Device/EASY80920NAND
+ $(Device/lantiqFullImage)
DEVICE_PROFILE := EASY80920NAND
IMAGE_SIZE := 64512k
DEVICE_TITLE := Lantiq VR9 - EASY80920NAND