summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-02-01 14:37:35 +0000
committerJohn Crispin <john@openwrt.org>2011-02-01 14:37:35 +0000
commit1e89df511a1506c0d476466f7cb60950522e51e3 (patch)
tree9030ad26ad3d83cda1743b31ce16add02d240f47 /target/linux/lantiq/image
parente919bd002a7f08d1c893dc3272f1f6332442fc35 (diff)
downloadmaster-31e0f0ae-1e89df511a1506c0d476466f7cb60950522e51e3.tar.gz
master-31e0f0ae-1e89df511a1506c0d476466f7cb60950522e51e3.tar.bz2
master-31e0f0ae-1e89df511a1506c0d476466f7cb60950522e51e3.zip
* adds profiles to the kernel * fixes 2 compile errors in the usb driver * ioports were not allocated properly
SVN-Revision: 25278
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile46
1 files changed, 41 insertions, 5 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 2d6acc8d41..b580c99e2d 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -55,31 +55,59 @@ define Image/BuildKernel/Template
endef
ifeq ($(CONFIG_SOC_LANTIQ_XWAY),y)
-define Image/BuildKernel
+define Image/BuildKernel/Profile/EASY50712
+ $(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/EASY50712
+ $(call Image/Build/$(1),$(1),EASY50712)
+endef
+
+define Image/BuildKernel/Profile/EASY50812
+ $(call Image/BuildKernel/Template,EASY50812,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/EASY50812
+ $(call Image/Build/$(1),$(1),EASY50812)
+endef
+
+define Image/BuildKernel/Profile/ARV752DPW22
+ $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV752DPW22
+ $(call Image/Build/$(1),$(1),ARV752DPW22)
+endef
+
+define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,EASY4010,$(xway_cmdline))
$(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
$(call Image/BuildKernel/Template,EASY50812,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV4510PW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV4518PW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV4520PW,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV452CPW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV4525PW,$(xway_cmdline))
- $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
-define Image/Build
+define Image/Build/Profile/Generic
$(call Image/Build/$(1),$(1),EASY4010)
$(call Image/Build/$(1),$(1),EASY50712)
$(call Image/Build/$(1),$(1),EASY50812)
$(call Image/Build/$(1),$(1),ARV4510PW)
$(call Image/Build/$(1),$(1),ARV4518PW)
$(call Image/Build/$(1),$(1),ARV4520PW)
+ $(call Image/Build/$(1),$(1),ARV452CPW)
$(call Image/Build/$(1),$(1),ARV4525PW)
- $(call Image/Build/$(1),$(1),ARV752DPW)
$(call Image/Build/$(1),$(1),ARV7518PW)
+ $(call Image/Build/$(1),$(1),ARV752DPW)
+ $(call Image/Build/$(1),$(1),ARV752DPW22)
$(call Image/Build/$(1),$(1),NONE)
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
endef
endif
@@ -96,4 +124,12 @@ define Image/Build
endef
endif
+define Image/BuildKernel
+ $(call Image/BuildKernel/Profile/$(PROFILE))
+endef
+
+define Image/Build
+ $(call Image/Build/Profile/$(PROFILE),$(1))
+endef
+
$(eval $(call BuildImage))