summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-30 12:18:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-30 12:18:22 +0000
commit1bc35a08d1d5c82b0e1d5f4f75c4edd721bb7e17 (patch)
tree83d3a1bede766b672f72ea2eaf94365fc0b6e13d /target/linux/lantiq/image
parentefb2c403cfacc463e2479c5fc73d58895e48a6c1 (diff)
downloadmaster-31e0f0ae-1bc35a08d1d5c82b0e1d5f4f75c4edd721bb7e17.tar.gz
master-31e0f0ae-1bc35a08d1d5c82b0e1d5f4f75c4edd721bb7e17.tar.bz2
master-31e0f0ae-1bc35a08d1d5c82b0e1d5f4f75c4edd721bb7e17.zip
lantiq: remove dead EASY33016 image recipe
Support for lantiq_svip_be has been removed a while ago, so EASY33016 images weren't buildable anymore. Remove the recipes as well as gzip compressed kernel support, as EASY33016 was the last user of it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46760
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 0627b5bd7c..7980627e4e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -60,22 +60,6 @@ define MkImageEVA
cat ./eva.dummy.squashfs >> $(KDIR)/$(1)$(2).eva.align.64k
endef
-define CompressGzip
- gzip -c $(1) > $(2)
-endef
-
-define PatchKernelGzip
- cp $(KDIR)/vmlinux$(3) $(KDIR)/vmlinux$(3)-$(1)
- $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux$(3)-$(1) '$(strip $(2))'
- $(call CompressGzip,$(KDIR)/vmlinux$(3)-$(1),$(KDIR)/vmlinux$(3)-$(1).gzip)
-endef
-
-define MkImageGzip
- mkimage -A mips -O linux -T kernel -a 0x80002000 -C gzip \
- -e 0x80002000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux$(2)-$(1).gzip $(KDIR)/uImage-$(1)$(2)
-endef
-
define Image/Build/squashfs
cat $(KDIR)/uImage-$(2) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
$(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image)
@@ -284,17 +268,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
-define Image/BuildKernelGzip/Template
- $(call PatchKernelGzip,$(1),$(if $(2),$(2) machtype=$(1),))
- $(call MkImageGzip,$(1))
- $(CP) $(KDIR)/uImage-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
- $(call PatchKernelGzip,$(1),$(if $(2),$(2) machtype=$(1),),-initramfs)
- $(call MkImageGzip,$(1),-initramfs)
- $(CP) $(KDIR)/uImage-$(1)-initramfs $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage-initramfs
-endif
-endef
-
ifeq ($(CONFIG_TARGET_lantiq_falcon),y)
@@ -457,14 +430,6 @@ endef
endif
-ifeq ($(CONFIG_TARGET_lantiq_svip_be),y)
-
-Image/BuildKernel/Profile/EASY33016=$(call Image/BuildKernelGzip/Template,EASY33016)
-Image/Build/Profile/EASY33016=$(call Image/Build/$(1),$(1),EASY33016)
-
-endif
-
-
define Image/BuildKernel
$(call Image/BuildKernel/Profile/$(PROFILE))
endef