summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/ar9
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-05-15 09:38:02 +0000
committerJohn Crispin <john@openwrt.org>2012-05-15 09:38:02 +0000
commit07dca108a96bcdb4e375d3a3f3b5e9701d661940 (patch)
tree07c2cdb2699f81a268a7b19154d9acd341422a26 /target/linux/lantiq/ar9
parent9785ec070ed99709512f3ddfeb821c15951418aa (diff)
downloadmaster-31e0f0ae-07dca108a96bcdb4e375d3a3f3b5e9701d661940.tar.gz
master-31e0f0ae-07dca108a96bcdb4e375d3a3f3b5e9701d661940.tar.bz2
master-31e0f0ae-07dca108a96bcdb4e375d3a3f3b5e9701d661940.zip
adds zyxel p2601hnfx support
Signed-off-by: Luka Perkov <openwrt@lukaperkov.net> SVN-Revision: 31734
Diffstat (limited to 'target/linux/lantiq/ar9')
-rw-r--r--target/linux/lantiq/ar9/config-default1
-rw-r--r--target/linux/lantiq/ar9/profiles/005-zyxel.mk7
2 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/lantiq/ar9/config-default b/target/linux/lantiq/ar9/config-default
index ce21adf42e..6a74179013 100644
--- a/target/linux/lantiq/ar9/config-default
+++ b/target/linux/lantiq/ar9/config-default
@@ -19,6 +19,7 @@ CONFIG_LANTIQ_MACH_FRITZ_AR9=y
# CONFIG_LANTIQ_MACH_GIGASX76X is not set
CONFIG_LANTIQ_MACH_NETGEAR=y
CONFIG_LANTIQ_MACH_WBMR=y
+CONFIG_LANTIQ_MACH_P2601HNFX=y
# CONFIG_LANTIQ_VRX200 is not set
CONFIG_MDIO_BOARDINFO=y
# CONFIG_MLX4_CORE is not set
diff --git a/target/linux/lantiq/ar9/profiles/005-zyxel.mk b/target/linux/lantiq/ar9/profiles/005-zyxel.mk
new file mode 100644
index 0000000000..8b1384c675
--- /dev/null
+++ b/target/linux/lantiq/ar9/profiles/005-zyxel.mk
@@ -0,0 +1,7 @@
+define Profile/P2601HNFX
+ NAME:=P2601HNFX - ZyXEL P-2601HN-Fx
+ PACKAGES:= kmod-usb-dwc-otg kmod-rt2800-usb wpad-mini \
+ kmod-ltq-dsl-firmware-b-ar9
+endef
+
+$(eval $(call Profile,P2601HNFX))