summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-11-10 00:16:35 +0000
committerLuka Perkov <luka@openwrt.org>2015-11-10 00:16:35 +0000
commit6acb552eeeb5f8917dfc4b7fe599fe9136cf2118 (patch)
treece0f17d6899f4d1ca10b3102ec927cb694da158f /target/linux/kirkwood
parent5d4bbb5f5b15efc93c5b0a34fe7d66b074820167 (diff)
downloadmaster-31e0f0ae-6acb552eeeb5f8917dfc4b7fe599fe9136cf2118.tar.gz
master-31e0f0ae-6acb552eeeb5f8917dfc4b7fe599fe9136cf2118.tar.bz2
master-31e0f0ae-6acb552eeeb5f8917dfc4b7fe599fe9136cf2118.zip
kirkwood: generate factory images for Linksys EA[34]500
This is done with the new image generation system and board names. It also generates a sysupgrade.tar image. Signed-off-by: Claudio Leite <leitec@staticky.com> SVN-Revision: 47432
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile45
-rw-r--r--target/linux/kirkwood/profiles/115-router.mk6
2 files changed, 39 insertions, 12 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 0aa75ff1fe..f90b303298 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -10,6 +10,45 @@ NAND_BLOCKSIZE := 2048-128k
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+DEVICE_VARS += DEVICE_DTS KERNEL_SIZE PAGESIZE BLOCKSIZE SUBPAGESIZE
+KERNEL_LOADADDR:=0x8000
+TARGET_DEVICES = linksys-audi linksys-viper
+
+define Device/Default
+ KERNEL := kernel-bin | append-dtb | uImage none
+ KERNEL_NAME := zImage
+endef
+
+define Device/linksys-audi
+ DEVICE_DTS := kirkwood-linksys-audi
+ PAGESIZE := 512
+ SUBPAGESIZE := 256
+ BLOCKSIZE := 16KiB
+ KERNEL_SIZE := 2624k
+ FILESYSTEMS := squashfs
+ PROFILES := EA3500
+ IMAGES := factory.bin sysupgrade.tar
+ IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/sysupgrade.tar := sysupgrade-nand
+endef
+
+define Device/linksys-viper
+ DEVICE_DTS := kirkwood-linksys-viper
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ BLOCKSIZE := 128KiB
+ KERNEL_SIZE := 2688k
+ FILESYSTEMS := squashfs
+ PROFILES := EA4500
+ IMAGES := factory.bin sysupgrade.tar
+ IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/sysupgrade.tar := sysupgrade-nand
+endef
+
+define Build/append-dtb
+ cat $(DTS_DIR)/$(DEVICE_DTS).dtb >> $@
+endef
+
define Image/BuildKernel/Template
$(CP) $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
@@ -109,12 +148,6 @@ Image/InstallKernel/Template/Generic=$(call Image/InstallKernel/Template)
Image/BuildKernel/Template/DOCKSTAR=$(call Image/BuildKernel/Template,dockstar)
Image/InstallKernel/Template/DOCKSTAR=$(call Image/InstallKernel/Template,dockstar)
-Image/BuildKernel/Template/EA3500=$(call Image/BuildKernel/Template,ea3500)
-Image/InstallKernel/Template/EA3500=$(call Image/InstallKernel/Template,ea3500)
-
-Image/BuildKernel/Template/EA4500=$(call Image/BuildKernel/Template,ea4500)
-Image/InstallKernel/Template/EA4500=$(call Image/InstallKernel/Template,ea4500)
-
Image/BuildKernel/Template/GOFLEXHOME=$(call Image/BuildKernel/Template,goflexhome)
Image/InstallKernel/Template/GOFLEXHOME=$(call Image/InstallKernel/Template,goflexhome)
diff --git a/target/linux/kirkwood/profiles/115-router.mk b/target/linux/kirkwood/profiles/115-router.mk
index f273f36077..c01bef7020 100644
--- a/target/linux/kirkwood/profiles/115-router.mk
+++ b/target/linux/kirkwood/profiles/115-router.mk
@@ -16,9 +16,6 @@ define Profile/EA3500/Description
Package set compatible with Linksys EA3500 board.
endef
-EA3500_UBIFS_OPTS:="-m 512 -e 15872 -c 4096"
-EA3500_UBI_OPTS:="-m 512 -p 16384 -s 256"
-
$(eval $(call Profile,EA3500))
define Profile/EA4500
@@ -32,7 +29,4 @@ define Profile/EA4500/Description
Package set compatible with Linksys EA4500 board.
endef
-EA4500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-EA4500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
$(eval $(call Profile,EA4500))