summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-11 19:05:20 +0200
committerMathias Kresin <dev@kresin.me>2016-09-13 19:36:41 +0200
commit61c2a7339a70b34cc357f9f190921365c39073f9 (patch)
tree147d330471abdc1c7908ab37608ca547bcca93f1 /target/linux/kirkwood
parent14b40d61e13ce0408d5ed9dff2ad3a18ab0c2471 (diff)
downloadmaster-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.tar.gz
master-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.tar.bz2
master-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.zip
image: remove padding parameter from append-kernel/append-rootfs
Using pad-to instead of passing the optional padding to append-kernel or append-rootfs. It could be that the value of a variable is passed. In case the variable is empty no error is thrown. Furthermore the purpose of the extra parameter is hard to get without reading the code. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 12d2a311ef..80bd01942e 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -59,7 +59,7 @@ define Device/linksys-audi
FILESYSTEMS := squashfs
PROFILES := Generic AUDI
IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
define Device/linksys-viper
@@ -68,7 +68,7 @@ define Device/linksys-viper
FILESYSTEMS := squashfs
PROFILES := Generic VIPER
IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
define Image/BuildKernel/Template