summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-11-11 12:48:30 +0000
committerLuka Perkov <luka@openwrt.org>2015-11-11 12:48:30 +0000
commit4e239d9fdbad9f125b2a82eb2eb39041ac87c1da (patch)
treed849f3626d0c88ecfd5b0b99250d35ea84b4e0e6 /target/linux/kirkwood
parent2f8ebe10b91c39963ae88cb2e17250c8fff77146 (diff)
downloadmaster-31e0f0ae-4e239d9fdbad9f125b2a82eb2eb39041ac87c1da.tar.gz
master-31e0f0ae-4e239d9fdbad9f125b2a82eb2eb39041ac87c1da.tar.bz2
master-31e0f0ae-4e239d9fdbad9f125b2a82eb2eb39041ac87c1da.zip
kirkwood: add Linksys routers to default profile
Signed-off-by: Claudio Leite <leitec@staticky.com> SVN-Revision: 47458
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile4
-rw-r--r--target/linux/kirkwood/profiles/100-generic.mk3
2 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 06b72240e6..3fc84aa756 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -26,7 +26,7 @@ define Device/linksys-audi
BLOCKSIZE := 16KiB
KERNEL_SIZE := 2624k
FILESYSTEMS := squashfs
- PROFILES := AUDI
+ PROFILES := Generic AUDI
IMAGES := factory.bin sysupgrade.tar
IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
IMAGE/sysupgrade.tar := sysupgrade-nand
@@ -39,7 +39,7 @@ define Device/linksys-viper
BLOCKSIZE := 128KiB
KERNEL_SIZE := 2688k
FILESYSTEMS := squashfs
- PROFILES := VIPER
+ PROFILES := Generic VIPER
IMAGES := factory.bin sysupgrade.tar
IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
IMAGE/sysupgrade.tar := sysupgrade-nand
diff --git a/target/linux/kirkwood/profiles/100-generic.mk b/target/linux/kirkwood/profiles/100-generic.mk
index 770bbaee1b..f07cea80d6 100644
--- a/target/linux/kirkwood/profiles/100-generic.mk
+++ b/target/linux/kirkwood/profiles/100-generic.mk
@@ -11,7 +11,8 @@ define Profile/Generic
kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
kmod-i2c-core kmod-i2c-mv64xxx \
kmod-ata-core kmod-ata-marvell-sata \
- kmod-rtc-marvell kmod-thermal-kirkwood
+ kmod-rtc-marvell kmod-thermal-kirkwood \
+ kmod-mwl8k swconfig wpad-mini
endef
define Profile/Generic/Description