summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-01 21:30:40 +0000
committerJohn Crispin <john@openwrt.org>2014-12-01 21:30:40 +0000
commitb5675ad92a4d8801d4a90c761c0e77ac69750c0d (patch)
tree752bcf05ac216901d21d58ef171116c5db744afa /target/linux/kirkwood
parent9b5f5839066ff8958c0bb468623db3a82a9806be (diff)
downloadmaster-31e0f0ae-b5675ad92a4d8801d4a90c761c0e77ac69750c0d.tar.gz
master-31e0f0ae-b5675ad92a4d8801d4a90c761c0e77ac69750c0d.tar.bz2
master-31e0f0ae-b5675ad92a4d8801d4a90c761c0e77ac69750c0d.zip
kirkwood: enable mvsw6171 switch driver on EA4500
Signed-off-by: Claudio Leite <leitec@staticky.com> SVN-Revision: 43487
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/config-3.142
-rw-r--r--target/linux/kirkwood/patches-3.14/160-ea4500.patch13
-rw-r--r--target/linux/kirkwood/profiles/115-router.mk2
3 files changed, 15 insertions, 2 deletions
diff --git a/target/linux/kirkwood/config-3.14 b/target/linux/kirkwood/config-3.14
index 2a59122341..641b0f840e 100644
--- a/target/linux/kirkwood/config-3.14
+++ b/target/linux/kirkwood/config-3.14
@@ -206,6 +206,7 @@ CONFIG_MVEBU_CLK_COMMON=y
CONFIG_MVEBU_MBUS=y
CONFIG_MVMDIO=y
# CONFIG_MVNETA is not set
+CONFIG_MVSW6171_PHY=y
CONFIG_NEED_DMA_MAP_STATE=y
CONFIG_NEED_KUSER_HELPERS=y
CONFIG_NEED_PER_CPU_KM=y
@@ -271,6 +272,7 @@ CONFIG_SPI=y
CONFIG_SPI_MASTER=y
CONFIG_SPI_ORION=y
CONFIG_SPLIT_PTLOCK_CPUS=999999
+CONFIG_SWCONFIG=y
CONFIG_SWIOTLB=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
CONFIG_TICK_CPU_ACCOUNTING=y
diff --git a/target/linux/kirkwood/patches-3.14/160-ea4500.patch b/target/linux/kirkwood/patches-3.14/160-ea4500.patch
index 0abf1a1c7c..eeed2a4f69 100644
--- a/target/linux/kirkwood/patches-3.14/160-ea4500.patch
+++ b/target/linux/kirkwood/patches-3.14/160-ea4500.patch
@@ -10,7 +10,7 @@
kirkwood-ib62x0.dtb \
--- /dev/null
+++ b/arch/arm/boot/dts/kirkwood-ea4500.dts
-@@ -0,0 +1,156 @@
+@@ -0,0 +1,167 @@
+/*
+ * kirkwood-ea4500.dts - Device Tree file for Linksys EA4500
+ *
@@ -120,6 +120,17 @@
+ gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
+ };
+ };
++
++ mvsw6171 {
++ compatible = "marvell,88e6171";
++ status = "okay";
++ reg = <0x10>;
++
++ mii-bus = <&mdio>;
++ cpu-port-0 = <5>;
++ cpu-port-1 = <6>;
++ is-indirect;
++ };
+};
+
+&nand {
diff --git a/target/linux/kirkwood/profiles/115-router.mk b/target/linux/kirkwood/profiles/115-router.mk
index ef7f228d2c..f255ca4846 100644
--- a/target/linux/kirkwood/profiles/115-router.mk
+++ b/target/linux/kirkwood/profiles/115-router.mk
@@ -25,7 +25,7 @@ define Profile/EA4500
NAME:=Linksys EA4500
PACKAGES:= \
kmod-mwl8k kmod-usb2 kmod-usb-storage \
- uboot-envtools
+ swconfig uboot-envtools
endef
define Profile/EA4500/Description