summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-31 12:04:04 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-31 12:04:04 +0000
commite00bc81a56da1b9aed2a4114ab64b8ea015507c5 (patch)
tree11c121110189270ae67593c23814a01d45a7a00e /target/linux/kirkwood/profiles
parent2b0fa00da8fc26e34f08680670f4637766bbd3e8 (diff)
downloadmaster-31e0f0ae-e00bc81a56da1b9aed2a4114ab64b8ea015507c5.tar.gz
master-31e0f0ae-e00bc81a56da1b9aed2a4114ab64b8ea015507c5.tar.bz2
master-31e0f0ae-e00bc81a56da1b9aed2a4114ab64b8ea015507c5.zip
kirkwood: add userland support for Pogoplug E02
This patch adds the userland support for the Pogoplug E02 by Cloud Engines, Inc. Signed-off-by: Felix Kaechele <heffer@fedoraproject.org> SVN-Revision: 38631
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/120-pogoplug.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/120-pogoplug.mk b/target/linux/kirkwood/profiles/120-pogoplug.mk
new file mode 100644
index 0000000000..0f842494ab
--- /dev/null
+++ b/target/linux/kirkwood/profiles/120-pogoplug.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/POGOE02
+ NAME:=Cloud Engines Pogoplug E02
+ PACKAGES:= \
+ kmod-usb2 kmod-usb-storage uboot-envtools
+endef
+
+define Profile/POGOE02/Description
+ Package set compatible with Cloud Engines Pogoplug E02 board.
+endef
+
+POGOE02_UBIFS_OPTS:="-m 2048 -e 128KiB -c 4096 -U"
+POGOE02_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,POGOE02))