summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-26 09:00:48 +0000
committerJohn Crispin <john@openwrt.org>2014-11-26 09:00:48 +0000
commit8dfb87bebc2c64863d75c0248b73a7144c3c00c9 (patch)
tree41181e9d2aa0627a70f4149150abe180e5ac2209 /target/linux/kirkwood/profiles
parentde49133a8b20650771fd844f3a5454513f6bf0f6 (diff)
downloadmaster-31e0f0ae-8dfb87bebc2c64863d75c0248b73a7144c3c00c9.tar.gz
master-31e0f0ae-8dfb87bebc2c64863d75c0248b73a7144c3c00c9.tar.bz2
master-31e0f0ae-8dfb87bebc2c64863d75c0248b73a7144c3c00c9.zip
kirkwood: Add support for Iomega StorCenter ix2-200
Signed-off-by: Richard Kunze <richard.kunze@web.de> SVN-Revision: 43391
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index eff59528a0..1bd188c11e 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -84,3 +84,22 @@ POGOE02_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
POGOE02_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,POGOE02))
+
+
+define Profile/IOMEGA_IX2_200
+ NAME:=Iomega StorCenter ix2-200
+ PACKAGES:= \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/IOMEGA_IX2_200/Description
+ Package set compatible with Iomega StorCenter ix2-200 board.
+endef
+
+IOMEGA_IX2_200_UBIFS_OPTS:="-m 512 -e 15872 -c 2048"
+IOMEGA_IX2_200_UBI_OPTS:="-m 512 -p 16384 -s 256"
+
+$(eval $(call Profile,IOMEGA_IX2_200))
+