summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-11-23 15:55:10 +0000
committerLuka Perkov <luka@openwrt.org>2013-11-23 15:55:10 +0000
commit746ace4baf1ee3a2bebb32851784208eb4168b91 (patch)
treea6cfb360dabb62e3fbc9900cbb29dbc07300cb95 /target/linux/kirkwood/profiles
parentc11bd50d77f8a9786f13984da20c0b0bddd58eac (diff)
downloadmaster-31e0f0ae-746ace4baf1ee3a2bebb32851784208eb4168b91.tar.gz
master-31e0f0ae-746ace4baf1ee3a2bebb32851784208eb4168b91.tar.bz2
master-31e0f0ae-746ace4baf1ee3a2bebb32851784208eb4168b91.zip
kirkwood: add support for iomega iconnect
Signed-off-by: Luka Perkov <luka@openwrt.org> Signed-off-by: Daniel Engberg <daniel.engberg@pyret.net> SVN-Revision: 38897
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index ebb71b76b8..185318d980 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -22,6 +22,21 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,DOCKSTAR))
+define Profile/ICONNECT
+ NAME:=Iomega Iconnect
+ PACKAGES:= \
+ kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/ICONNECT/Description
+ Package set compatible with Iomega Iconnect board.
+endef
+
+ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,ICONNECT))
+
define Profile/IB62X0
NAME:=RaidSonic ICY BOX IB-NAS62x0
PACKAGES:= \