summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-05-08 20:12:39 +0000
committerLuka Perkov <luka@openwrt.org>2015-05-08 20:12:39 +0000
commit7437be53bae03b3d3ee5c3b32ad9f159834d9452 (patch)
tree84cb8c3be9643fe4382d1072c4e8dd527314be71 /target/linux/kirkwood/profiles
parent7b01a650f8ad8d22c360d359432ffe5365bbee4f (diff)
downloadmaster-31e0f0ae-7437be53bae03b3d3ee5c3b32ad9f159834d9452.tar.gz
master-31e0f0ae-7437be53bae03b3d3ee5c3b32ad9f159834d9452.tar.bz2
master-31e0f0ae-7437be53bae03b3d3ee5c3b32ad9f159834d9452.zip
kirkwood: add support for the Seagate GoflexHome
Add Support for the Seagate GoflexHome <http://wiki.openwrt.org/toh/seagate/goflexhome> Signed-off-by: L. D. Pinney <ldpinney@gmail.com> SVN-Revision: 45647
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index d87c45c2bf..748efacd56 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -20,6 +20,23 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,DOCKSTAR))
+define Profile/GOFLEXHOME
+ NAME:=Seagate GoFlexHome
+ PACKAGES:= \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/GOFLEXHOME/Description
+ Package set compatible with Seagate GoFlexHome
+endef
+
+GOFLEXHOME_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+GOFLEXHOME_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,GOFLEXHOME))
+
define Profile/GOFLEXNET
NAME:=Seagate GoFlexNet
PACKAGES:= \