summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-11-01 01:13:16 +0000
committerLuka Perkov <luka@openwrt.org>2015-11-01 01:13:16 +0000
commit6a18146206c18daae5f2a8a4a203b3fc53745f58 (patch)
tree1c5f256590bc0719ff9d8cc6b161012e7f5f80a1 /target/linux/kirkwood/profiles
parent013a114691e74c9eb76eb2becd7f4878a1fc7f59 (diff)
downloadmaster-31e0f0ae-6a18146206c18daae5f2a8a4a203b3fc53745f58.tar.gz
master-31e0f0ae-6a18146206c18daae5f2a8a4a203b3fc53745f58.tar.bz2
master-31e0f0ae-6a18146206c18daae5f2a8a4a203b3fc53745f58.zip
kirkwood: add initial support for NSA310s
Signed-off-by: Tony Dinh <mibodhi@gmail.com> Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 47330
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index 748efacd56..bf97437871 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -100,6 +100,22 @@ IOMEGA_IX2_200_UBI_OPTS:="-m 512 -p 16384 -s 256"
$(eval $(call Profile,IOMEGA_IX2_200))
+define Profile/NSA310S
+ NAME:=ZyXEL NSA310S
+ PACKAGES:= \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/NSA310S/Description
+ Package set compatible with ZyXEL NSA310S board.
+endef
+
+NSA310S_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+NSA310S_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,NSA310S))
+
define Profile/POGOE02
NAME:=Cloud Engines Pogoplug E02
PACKAGES:= \