summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-11-10 23:55:10 +0000
committerLuka Perkov <luka@openwrt.org>2014-11-10 23:55:10 +0000
commit4f1a9470f067cc5df76571e9d06b7d9240fcc0a3 (patch)
tree92e637a61e2a6bb04dc14c438e517fe352a01998 /target/linux/kirkwood/profiles
parenta69ebe234d46ca95cbcbcba7f4ef9bae598eb95b (diff)
downloadmaster-31e0f0ae-4f1a9470f067cc5df76571e9d06b7d9240fcc0a3.tar.gz
master-31e0f0ae-4f1a9470f067cc5df76571e9d06b7d9240fcc0a3.tar.bz2
master-31e0f0ae-4f1a9470f067cc5df76571e9d06b7d9240fcc0a3.zip
kirkwood: add support for Linksys EA3500
http://wiki.openwrt.org/toh/linksys/ea3500 Signed-off-by: Dan Walters <dan@walters.io> SVN-Revision: 43230
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/115-router.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/115-router.mk b/target/linux/kirkwood/profiles/115-router.mk
index 000aa7418f..ef7f228d2c 100644
--- a/target/linux/kirkwood/profiles/115-router.mk
+++ b/target/linux/kirkwood/profiles/115-router.mk
@@ -5,6 +5,22 @@
# See /LICENSE for more information.
#
+define Profile/EA3500
+ NAME:=Linksys EA3500
+ PACKAGES:= \
+ kmod-mwl8k kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/EA3500/Description
+ Package set compatible with Linksys EA3500 board.
+endef
+
+EA3500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+EA3500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,EA3500))
+
define Profile/EA4500
NAME:=Linksys EA4500
PACKAGES:= \