summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-12-17 08:33:55 +0000
committerLuka Perkov <luka@openwrt.org>2014-12-17 08:33:55 +0000
commit309e74b86d9d9542e2c21d449433bb0889f068e3 (patch)
treecda5a0607d7b9cbb9757c9c2cab2089fba4c8498 /target/linux/kirkwood/profiles
parent211cac98d559fdcb11fd0825aaf165da15c87b71 (diff)
downloadmaster-31e0f0ae-309e74b86d9d9542e2c21d449433bb0889f068e3.tar.gz
master-31e0f0ae-309e74b86d9d9542e2c21d449433bb0889f068e3.tar.bz2
master-31e0f0ae-309e74b86d9d9542e2c21d449433bb0889f068e3.zip
kirkwood: add sheevaplug and derivatives
Add kirkwood FDT: - SheevaPlug - SheevaPlug with eSATA - GuruplugServerPlus - Topkick1281P2 Signed-off-by: GĂ©rald Kerma <drEagle@doukki.net> SVN-Revision: 43735
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/120-plug.mk78
1 files changed, 78 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/120-plug.mk b/target/linux/kirkwood/profiles/120-plug.mk
new file mode 100644
index 0000000000..cca703f445
--- /dev/null
+++ b/target/linux/kirkwood/profiles/120-plug.mk
@@ -0,0 +1,78 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/SHEEVAPLUG
+ NAME:=Globalscale Technologies SheevaPlug
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core uboot-envtools
+endef
+
+define Profile/SHEEVAPLUG/Description
+ Package set compatible with Globalscale Technologies SheevaPlug board.
+endef
+
+SHEEVAPLUG_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+SHEEVAPLUG_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,SHEEVAPLUG))
+
+define Profile/SHEEVAPLUGSATA
+ NAME:=Globalscale Technologies eSATA SheevaPlug
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ uboot-envtools
+endef
+
+define Profile/SHEEVAPLUGSATA/Description
+ Package set compatible with Globalscale Technologies eSATA SheevaPlug board.
+endef
+
+SHEEVAPLUGSATA_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+SHEEVAPLUGSATA_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,SHEEVAPLUGSATA))
+
+define Profile/GuruplugServerPlus
+ NAME:=Globalscale Technologies Guruplug Server Plus
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-btmrvl kmod-btmrvl-sdio kmod-libertas kmod-libertas-sdio \
+ uboot-envtools
+endef
+
+define Profile/GuruplugServerPlus/Description
+ Package set compatible with Globalscale Technologies Guruplug Server Plus board.
+endef
+
+GuruplugServerPlus_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+GuruplugServerPlus_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,GuruplugServerPlus))
+
+define Profile/Topkick1281P2
+ NAME:=Univeral Scientific Industrial Co. Topkick-1281P2
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ uboot-envtools
+endef
+
+define Profile/Topkick1281P2/Description
+ Package set compatible with Univeral Scientific Industrial Co. Topkick-1281P2 board.
+endef
+
+Topkick1281P2_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+Topkick1281P2_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,Topkick1281P2))