summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-02-15 23:53:08 +0000
committerLuka Perkov <luka@openwrt.org>2014-02-15 23:53:08 +0000
commit0c25f159fd44c20c13a37148ff91b283c307dcfe (patch)
tree3038e618b22054be20dee33ec16867c65257ec44 /target/linux/kirkwood/profiles
parent777e7c3ff5d0030dc7d24a43b70dfd2d3b2a5a4c (diff)
downloadmaster-31e0f0ae-0c25f159fd44c20c13a37148ff91b283c307dcfe.tar.gz
master-31e0f0ae-0c25f159fd44c20c13a37148ff91b283c307dcfe.tar.bz2
master-31e0f0ae-0c25f159fd44c20c13a37148ff91b283c307dcfe.zip
kirkwood: update support for iconnect
Previous patch was pushed due to false user report. While at it fix alphabetic ordering. The board is optimized for ubi(fs) and boots OpenWrt without changes to uboot environment if OpenWrt's uboot package is used. In order to flash the image run following commands in uboot shell: nand erase 0x200000 0x1fe00000 ubi part root ; ubi remove rootfs ; ubi create rootfs tftpboot 0x800000 openwrt-kirkwood-iconnect-rootfs.ubifs ; ubi write 0x800000 rootfs ${filesize} ; reset Signed-off-by: Luka Perkov <luka@openwrt.org> CC: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39591
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index 07a9797e55..6605f69362 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -22,21 +22,6 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,DOCKSTAR))
-define Profile/ICONNECT
- NAME:=Iomega Iconnect
- PACKAGES:= \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/ICONNECT/Description
- Package set compatible with Iomega Iconnect board.
-endef
-
-ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
-$(eval $(call Profile,ICONNECT))
-
define Profile/IB62X0
NAME:=RaidSonic ICY BOX IB-NAS62x0
PACKAGES:= \
@@ -53,3 +38,18 @@ IB62X0_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
IB62X0_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,IB62X0))
+
+define Profile/ICONNECT
+ NAME:=Iomega Iconnect
+ PACKAGES:= \
+ kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/ICONNECT/Description
+ Package set compatible with Iomega Iconnect board.
+endef
+
+ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,ICONNECT))