summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles/110-nas.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-11-06 19:24:32 +0000
committerLuka Perkov <luka@openwrt.org>2013-11-06 19:24:32 +0000
commitb2943192155ee094ecd42df11181c5fb55fc19e6 (patch)
tree383865c7de073d8737b65d637f370deefb484ec4 /target/linux/kirkwood/profiles/110-nas.mk
parentd9c9633d194fd3059464a280854862807b1b98d9 (diff)
downloadmaster-31e0f0ae-b2943192155ee094ecd42df11181c5fb55fc19e6.tar.gz
master-31e0f0ae-b2943192155ee094ecd42df11181c5fb55fc19e6.tar.bz2
master-31e0f0ae-b2943192155ee094ecd42df11181c5fb55fc19e6.zip
kirkwood: add support for dockstar
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38664
Diffstat (limited to 'target/linux/kirkwood/profiles/110-nas.mk')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index 28b180223c..ebb71b76b8 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -5,6 +5,23 @@
# See /LICENSE for more information.
#
+define Profile/DOCKSTAR
+ NAME:=Seagate FreeAgent Dockstar
+ PACKAGES:= \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/DOCKSTAR/Description
+ Package set compatible with Seagate FreeAgent Dockstar board.
+endef
+
+DOCKSTAR_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096 -U"
+DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,DOCKSTAR))
+
define Profile/IB62X0
NAME:=RaidSonic ICY BOX IB-NAS62x0
PACKAGES:= \