summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
commitdbe4173b206b4180e1ce03e545b63ab40ccb1cc1 (patch)
treee5107e4b2e3379b96a3bab6ff7abcf87f03242af /target/linux/kirkwood/image
parent3368b4799b527a4179d9eac77acc90ce81125964 (diff)
downloadmaster-31e0f0ae-dbe4173b206b4180e1ce03e545b63ab40ccb1cc1.tar.gz
master-31e0f0ae-dbe4173b206b4180e1ce03e545b63ab40ccb1cc1.tar.bz2
master-31e0f0ae-dbe4173b206b4180e1ce03e545b63ab40ccb1cc1.zip
image: fix jffs2(_nand) image generation
Variables dependend on JFFS2_BLOCKSIZE and NANDBLOCK_SIZE are used for template generation, so need to be present before inclusion of image.mk in target image Makefiles. So move all declarations to before any includes. Fixes: r42878 ("image.mk: clean up and parallelize mkfs calls") Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46564
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 8413a41ba3..019806c985 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -4,11 +4,12 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE := 2048-128k
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
define sanitize_profile_name
$(shell echo $(PROFILE) | tr '[:upper:]' '[:lower:]')
endef