summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-03 02:50:02 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-03 02:50:02 +0000
commita30df8987d472e727bdd8b482e386b223b55c024 (patch)
treeb08035611808657f1bb1f775a71bb2abeb0db035 /target/linux/kirkwood/image
parent38936426f7d4d569f918cb2ca646263b4c38e25b (diff)
downloadmaster-31e0f0ae-a30df8987d472e727bdd8b482e386b223b55c024.tar.gz
master-31e0f0ae-a30df8987d472e727bdd8b482e386b223b55c024.tar.bz2
master-31e0f0ae-a30df8987d472e727bdd8b482e386b223b55c024.zip
kirkwood: fix initramfs images
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38296
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 1dfe45f494..dbf8877652 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,8 +10,10 @@ include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE := 2048:128k
define Image/BuildKernel
-# do mach-id fixup here, if needed
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(CP) $(KDIR)/uImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-uImage-initramfs
+endif
endef
define Image/Build