summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-03-27 09:28:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-03-27 09:28:33 +0000
commit627baa28d33ca202e0f79e9a2a8eb6bc9d823a1a (patch)
tree72d6e2a751ac1c6e7b846d285867e11225fca13a /target/linux/ixp4xx
parentb68564ed3fd56d381886c08fc4b2640dd15b46ba (diff)
downloadmaster-31e0f0ae-627baa28d33ca202e0f79e9a2a8eb6bc9d823a1a.tar.gz
master-31e0f0ae-627baa28d33ca202e0f79e9a2a8eb6bc9d823a1a.tar.bz2
master-31e0f0ae-627baa28d33ca202e0f79e9a2a8eb6bc9d823a1a.zip
kernel: update 3.10 to 3.10.34
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 40291
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 9a7d50997b..c3cb734e45 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic harddisk
-LINUX_VERSION:=3.10.32
+LINUX_VERSION:=3.10.34
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch b/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch
index c46f516bd6..c435623588 100644
--- a/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch
+++ b/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch
@@ -1,6 +1,6 @@
--- a/net/core/skbuff.c
+++ b/net/core/skbuff.c
-@@ -208,6 +208,9 @@ struct sk_buff *__alloc_skb(unsigned int
+@@ -210,6 +210,9 @@ struct sk_buff *__alloc_skb(unsigned int
if (sk_memalloc_socks() && (flags & SKB_ALLOC_RX))
gfp_mask |= __GFP_MEMALLOC;
@@ -10,7 +10,7 @@
/* Get the HEAD */
skb = kmem_cache_alloc_node(cache, gfp_mask & ~__GFP_DMA, node);
-@@ -1052,6 +1055,10 @@ int pskb_expand_head(struct sk_buff *skb
+@@ -1054,6 +1057,10 @@ int pskb_expand_head(struct sk_buff *skb
if (skb_shared(skb))
BUG();