summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-29 12:20:39 +0000
committerJohn Crispin <john@openwrt.org>2015-05-29 12:20:39 +0000
commit590be1fd872e39b54a3bd23949e76b7af375b68b (patch)
treefb67b50609a37f07ec481f4b3f9a07c005411381 /target/linux/ixp4xx
parent0d7666fd73d774b8b2b69ea52d0a86a774c66b83 (diff)
downloadmaster-31e0f0ae-590be1fd872e39b54a3bd23949e76b7af375b68b.tar.gz
master-31e0f0ae-590be1fd872e39b54a3bd23949e76b7af375b68b.tar.bz2
master-31e0f0ae-590be1fd872e39b54a3bd23949e76b7af375b68b.zip
ixp4xx: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45826
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 7488d757b6..bbd62f0513 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/image.mk
ifdef CONFIG_PACKAGE_apex
define Image/Build/Linksys
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -L $(BIN_DIR)/apex/apex-$(2)-armeb.bin \
+ -L $(KDIR)/apex-$(2)-armeb.bin \
-k $(BIN_DIR)/$(IMG_PREFIX)-$(2)-zImage \
-r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -F -L $(BIN_DIR)/apex/apex-$(2)-16mb-armeb.bin \
+ -F -L $(KDIR)/apex-$(2)-16mb-armeb.bin \
-k $(BIN_DIR)/$(IMG_PREFIX)-$(2)-zImage \
-r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-16mb.bin