summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-11-30 11:17:45 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-11-30 11:17:45 +0000
commite5f65cb39a44537a4446dd7f6bedd612c84810dc (patch)
treef5dcfaa05c2d8ecc25e505d96aab14dbc3c14216 /target/linux/ixp4xx
parent1450355ca37860eb17a6a538462a401bdfd54476 (diff)
downloadmaster-31e0f0ae-e5f65cb39a44537a4446dd7f6bedd612c84810dc.tar.gz
master-31e0f0ae-e5f65cb39a44537a4446dd7f6bedd612c84810dc.tar.bz2
master-31e0f0ae-e5f65cb39a44537a4446dd7f6bedd612c84810dc.zip
refresh patches
SVN-Revision: 13443
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/patches-2.6.27/185-mi424wr_support.patch28
-rw-r--r--target/linux/ixp4xx/patches-2.6.27/400-dmabounce.patch2
-rw-r--r--target/linux/ixp4xx/patches-2.6.27/500-usr8200_support.patch34
3 files changed, 27 insertions, 37 deletions
diff --git a/target/linux/ixp4xx/patches-2.6.27/185-mi424wr_support.patch b/target/linux/ixp4xx/patches-2.6.27/185-mi424wr_support.patch
index ebdaf47c98..025f7e962d 100644
--- a/target/linux/ixp4xx/patches-2.6.27/185-mi424wr_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.27/185-mi424wr_support.patch
@@ -1,5 +1,5 @@
---- /dev/null 2008-04-22 17:51:32.000000000 -0400
-+++ b/arch/arm/mach-ixp4xx/mi424wr-pci.c 2008-09-19 10:59:48.000000000 -0400
+--- /dev/null
++++ b/arch/arm/mach-ixp4xx/mi424wr-pci.c
@@ -0,0 +1,71 @@
+/*
+ * arch/arm/mach-ixp4xx/mi424wr-pci.c
@@ -72,8 +72,8 @@
+
+subsys_initcall(mi424wr_pci_init);
+
---- /dev/null 2008-04-22 17:51:32.000000000 -0400
-+++ b/arch/arm/mach-ixp4xx/mi424wr-setup.c 2008-09-19 10:45:52.000000000 -0400
+--- /dev/null
++++ b/arch/arm/mach-ixp4xx/mi424wr-setup.c
@@ -0,0 +1,344 @@
+/*
+ * arch/arm/mach-ixp4xx/mi424wr-setup.c
@@ -419,9 +419,9 @@
+ .init_machine = mi424wr_init,
+MACHINE_END
+
---- a/arch/arm/mach-ixp4xx/Makefile 2008-07-15 14:20:22.000000000 -0400
-+++ b/arch/arm/mach-ixp4xx/Makefile 2008-07-13 17:29:53.000000000 -0400
-@@ -24,6 +24,7 @@
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
+@@ -23,6 +23,7 @@ obj-pci-$(CONFIG_MACH_COMPEX) += ixdp42
obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
obj-pci-$(CONFIG_MACH_AP1000) += ixdp425-pci.o
obj-pci-$(CONFIG_MACH_TW5334) += tw5334-pci.o
@@ -429,7 +429,7 @@
obj-y += common.o
-@@ -46,6 +47,7 @@
+@@ -44,6 +45,7 @@ obj-$(CONFIG_MACH_COMPEX) += compex-setu
obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
obj-$(CONFIG_MACH_AP1000) += ap1000-setup.o
obj-$(CONFIG_MACH_TW5334) += tw5334-setup.o
@@ -437,9 +437,9 @@
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
obj-$(CONFIG_IXP4XX_QMGR) += ixp4xx_qmgr.o
---- a/arch/arm/mach-ixp4xx/Kconfig 2008-07-05 18:53:22.000000000 -0400
-+++ b/arch/arm/mach-ixp4xx/Kconfig 2008-07-13 17:28:37.000000000 -0400
-@@ -237,6 +237,13 @@
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
+@@ -229,6 +229,13 @@ config MACH_GTWX5715
"High Speed" UART is n/c (as far as I can tell)
20 Pin ARM/Xscale JTAG interface on J2
@@ -453,9 +453,9 @@
comment "IXP4xx Options"
config DMABOUNCE
---- a/arch/arm/configs/ixp4xx_defconfig 2008-07-05 18:53:22.000000000 -0400
-+++ b/arch/arm/configs/ixp4xx_defconfig 2008-07-13 17:24:39.000000000 -0400
-@@ -172,6 +172,7 @@
+--- a/arch/arm/configs/ixp4xx_defconfig
++++ b/arch/arm/configs/ixp4xx_defconfig
+@@ -172,6 +172,7 @@ CONFIG_MACH_FSG=y
CONFIG_CPU_IXP46X=y
CONFIG_CPU_IXP43X=y
CONFIG_MACH_GTWX5715=y
diff --git a/target/linux/ixp4xx/patches-2.6.27/400-dmabounce.patch b/target/linux/ixp4xx/patches-2.6.27/400-dmabounce.patch
index 2fc1890c89..e88dc93e2a 100644
--- a/target/linux/ixp4xx/patches-2.6.27/400-dmabounce.patch
+++ b/target/linux/ixp4xx/patches-2.6.27/400-dmabounce.patch
@@ -13,7 +13,7 @@
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -244,6 +244,11 @@ config DMABOUNCE
+@@ -251,6 +251,11 @@ config DMABOUNCE
default y
depends on PCI
diff --git a/target/linux/ixp4xx/patches-2.6.27/500-usr8200_support.patch b/target/linux/ixp4xx/patches-2.6.27/500-usr8200_support.patch
index 629f537d5c..413fcae818 100644
--- a/target/linux/ixp4xx/patches-2.6.27/500-usr8200_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.27/500-usr8200_support.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.27.3.orig/arch/arm/mach-ixp4xx/Kconfig 2008-11-05 19:31:20.000000000 +0000
-+++ linux-2.6.27.3/arch/arm/mach-ixp4xx/Kconfig 2008-11-05 20:10:26.000000000 +0000
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
@@ -97,6 +97,14 @@ config MACH_SIDEWINDER
Engineering Sidewinder board. For more information on this
platform, see http://www.adiengineering.com
@@ -17,11 +15,9 @@ Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/Kconfig
config MACH_COMPEX
bool "Compex WP18 / NP18A"
select PCI
-Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.27.3.orig/arch/arm/mach-ixp4xx/Makefile 2008-11-05 19:31:20.000000000 +0000
-+++ linux-2.6.27.3/arch/arm/mach-ixp4xx/Makefile 2008-11-05 20:10:26.000000000 +0000
-@@ -24,6 +24,7 @@ obj-pci-$(CONFIG_MACH_COMPEX) += ixdp42
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
+@@ -25,6 +25,7 @@ obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt
obj-pci-$(CONFIG_MACH_AP1000) += ixdp425-pci.o
obj-pci-$(CONFIG_MACH_TW5334) += tw5334-pci.o
obj-pci-$(CONFIG_MACH_MI424WR) += mi424wr-pci.o
@@ -29,7 +25,7 @@ Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/Makefile
obj-y += common.o
-@@ -46,6 +47,7 @@ obj-$(CONFIG_MACH_COMPEX) += compex-setu
+@@ -48,6 +49,7 @@ obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv
obj-$(CONFIG_MACH_AP1000) += ap1000-setup.o
obj-$(CONFIG_MACH_TW5334) += tw5334-setup.o
obj-$(CONFIG_MACH_MI424WR) += mi424wr-setup.o
@@ -37,10 +33,8 @@ Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/Makefile
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
obj-$(CONFIG_IXP4XX_QMGR) += ixp4xx_qmgr.o
-Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/usr8200-pci.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.27.3/arch/arm/mach-ixp4xx/usr8200-pci.c 2008-11-05 22:51:20.000000000 +0000
+--- /dev/null
++++ b/arch/arm/mach-ixp4xx/usr8200-pci.c
@@ -0,0 +1,78 @@
+/*
+ * arch/arch/mach-ixp4xx/usr8200-pci.c
@@ -120,10 +114,8 @@ Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/usr8200-pci.c
+}
+
+subsys_initcall(usr8200_pci_init);
-Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/usr8200-setup.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.27.3/arch/arm/mach-ixp4xx/usr8200-setup.c 2008-11-05 20:23:32.000000000 +0000
+--- /dev/null
++++ b/arch/arm/mach-ixp4xx/usr8200-setup.c
@@ -0,0 +1,187 @@
+/*
+ * arch/arm/mach-ixp4xx/usr8200-setup.c
@@ -312,10 +304,8 @@ Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/usr8200-setup.c
+ .boot_params = 0x0100,
+ .init_machine = usr8200_init,
+MACHINE_END
-Index: linux-2.6.27.3/arch/arm/mach-ixp4xx/include/mach/uncompress.h
-===================================================================
---- linux-2.6.27.3.orig/arch/arm/mach-ixp4xx/include/mach/uncompress.h 2008-11-05 20:11:38.000000000 +0000
-+++ linux-2.6.27.3/arch/arm/mach-ixp4xx/include/mach/uncompress.h 2008-11-05 20:12:11.000000000 +0000
+--- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
++++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
@@ -43,7 +43,7 @@ static __inline__ void __arch_decomp_set
if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
machine_is_gateway7001() || machine_is_wg302v2() ||