summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/ixp4xx
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadmaster-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/image/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index f4fe4cae15..da8f0fdde6 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,12 +12,12 @@ ifdef CONFIG_PACKAGE_apex
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-L $(BIN_DIR)/apex/apex-$(2)-armeb.bin \
-k $(BIN_DIR)/openwrt-$(2)-zImage \
- -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
+ -r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/openwrt-$(2)-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-F -L $(BIN_DIR)/apex/apex-$(2)-16mb-armeb.bin \
-k $(BIN_DIR)/openwrt-$(2)-zImage \
- -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
+ -r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/openwrt-$(2)-$(1)-16mb.bin
endef
endif
@@ -36,7 +36,7 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
endef
@@ -45,18 +45,18 @@ define Image/Build
endef
define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=65536 conv=sync
endef
define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
$(call Image/Build/Linksys,$(1))
$(call Image/Build/Freecom,$(1),fsg3,$(1))
endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
$(call Image/Build/Linksys,$(1),nslu2,$(1))
$(call Image/Build/Freecom,$(1),fsg3,$(1))
endef