summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:16 +0000
commit4000de357e4b41f4978fe2344b3ff2073cc6c812 (patch)
tree1b02247234704ea99720b256da66adbd4501896c /target/linux/ixp4xx
parenta282e37c094fa3f634c2418a69069722dd439261 (diff)
downloadmaster-31e0f0ae-4000de357e4b41f4978fe2344b3ff2073cc6c812.tar.gz
master-31e0f0ae-4000de357e4b41f4978fe2344b3ff2073cc6c812.tar.bz2
master-31e0f0ae-4000de357e4b41f4978fe2344b3ff2073cc6c812.zip
move crypto module to target specific modules.mk
SVN-Revision: 32856
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/modules.mk b/target/linux/ixp4xx/modules.mk
index e088497793..8bf6e693b7 100644
--- a/target/linux/ixp4xx/modules.mk
+++ b/target/linux/ixp4xx/modules.mk
@@ -39,3 +39,20 @@ define KernelPackage/ixp4xx-beeper/description
endef
$(eval $(call KernelPackage,ixp4xx-beeper))
+
+
+define KernelPackage/crypto-hw-ixp4xx
+ TITLE:=Intel IXP4xx hardware crypto module
+ DEPENDS:=@TARGET_ixp4xx
+ KCONFIG:= \
+ CONFIG_CRYPTO_DEV_IXP4XX
+ FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+ AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+ $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+ Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))