summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:23 +0000
commit18038c803ceec789321bba836c8c5248da261508 (patch)
tree57d0882d0ec09c4db114dd5b4211cd0d93998e11 /target/linux/ixp4xx
parent53402a64b3b23d1916db0fc310c0cb936ad42369 (diff)
downloadmaster-31e0f0ae-18038c803ceec789321bba836c8c5248da261508.tar.gz
master-31e0f0ae-18038c803ceec789321bba836c8c5248da261508.tar.bz2
master-31e0f0ae-18038c803ceec789321bba836c8c5248da261508.zip
move ixp4xx-eth to target specific modules.mk
SVN-Revision: 32858
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/modules.mk b/target/linux/ixp4xx/modules.mk
index 8bf6e693b7..8377eec01e 100644
--- a/target/linux/ixp4xx/modules.mk
+++ b/target/linux/ixp4xx/modules.mk
@@ -56,3 +56,19 @@ define KernelPackage/crypto-hw-ixp4xx/description
endef
$(eval $(call KernelPackage,crypto-hw-ixp4xx))
+
+
+define KernelPackage/ixp4xx-eth
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=IXP4xxt Ethernet Adapter kernel support
+ DEPENDS:=@TARGET_ixp4xx
+ KCONFIG:=CONFIG_IXP4XX_ETH
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/xscale/ixp4xx_eth.ko
+ AUTOLOAD:=$(call AutoLoad,50,ixp4xx_eth)
+endef
+
+define KernelPackage/ixp4xx-eth/description
+ Kernel modules for Intel IXP4xx Ethernet chipsets.
+endef
+
+$(eval $(call KernelPackage,ixp4xx-eth))