summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
commit76d079204df113afa9e382a43abb5e1a2135150d (patch)
tree8e472ab203e8d6a47dc2e285b3becbfca35d04c6 /target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch
parent072937888e133f5e97fd05a7496eaf7eeae04079 (diff)
downloadmaster-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.gz
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.bz2
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.zip
kernel: update 3.18 to 3.18.14
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
Diffstat (limited to 'target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch')
-rw-r--r--target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch b/target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch
index 0d5119d624..97d4445334 100644
--- a/target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch
+++ b/target/linux/ixp4xx/patches-3.18/295-latch_led_driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -251,6 +251,12 @@ config LEDS_LP8788
+@@ -250,6 +250,12 @@ config LEDS_LP8788
help
This option enables support for the Keyboard LEDs on the LP8788 PMIC.
@@ -15,7 +15,7 @@
depends on LEDS_CLASS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -22,6 +22,7 @@ obj-$(CONFIG_LEDS_SUNFIRE) += leds-sunf
+@@ -21,6 +21,7 @@ obj-$(CONFIG_LEDS_SUNFIRE) += leds-sunf
obj-$(CONFIG_LEDS_PCA9532) += leds-pca9532.o
obj-$(CONFIG_LEDS_GPIO_REGISTER) += leds-gpio-register.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
@@ -180,7 +180,7 @@
+MODULE_DESCRIPTION("Latch LED driver");
--- a/include/linux/leds.h
+++ b/include/linux/leds.h
-@@ -285,4 +285,18 @@ static inline void ledtrig_cpu(enum cpu_
+@@ -297,4 +297,18 @@ static inline void ledtrig_cpu(enum cpu_
}
#endif