summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/image
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2009-03-22 12:35:44 +0000
committerRod Whitby <rod@whitby.id.au>2009-03-22 12:35:44 +0000
commite6b22c5fe28c625f8bf2f8cdf899165320a3d570 (patch)
tree4b1ad006a704e64642c27831936f51613df4992d /target/linux/ixp4xx/image
parent34ad500e2c02e25bed4a229f367347c209dc2d76 (diff)
downloadmaster-31e0f0ae-e6b22c5fe28c625f8bf2f8cdf899165320a3d570.tar.gz
master-31e0f0ae-e6b22c5fe28c625f8bf2f8cdf899165320a3d570.tar.bz2
master-31e0f0ae-e6b22c5fe28c625f8bf2f8cdf899165320a3d570.zip
ixp4xx/image: Initial support for fsg3 webupgrade images
SVN-Revision: 14962
Diffstat (limited to 'target/linux/ixp4xx/image')
-rw-r--r--target/linux/ixp4xx/image/Makefile32
1 files changed, 22 insertions, 10 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index ff3e501e47..2fec61b239 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -7,17 +7,27 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Image/Build/slug
+define Image/Build/Linksys
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -L $(BIN_DIR)/apex-nslu2-armeb.bin \
- -k $(BIN_DIR)/openwrt-nslu2-zImage \
+ -L $(BIN_DIR)/apex-$(2)-armeb.bin \
+ -k $(BIN_DIR)/openwrt-$(2)-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
- -p -o $(BIN_DIR)/openwrt-nslu2-$(1).bin
+ -p -o $(BIN_DIR)/openwrt-$(2)-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -F -L $(BIN_DIR)/apex-nslu2-16mb-armeb.bin \
- -k $(BIN_DIR)/openwrt-nslu2-zImage \
+ -F -L $(BIN_DIR)/apex-$(2)-16mb-armeb.bin \
+ -k $(BIN_DIR)/openwrt-$(2)-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
- -p -o $(BIN_DIR)/openwrt-nslu2-$(1)-16mb.bin
+ -p -o $(BIN_DIR)/openwrt-$(2)-$(1)-16mb.bin
+endef
+
+define Image/Build/Freecom
+ $(INSTALL_DIR) $(TARGET_DIR)/boot
+ # TODO: Add special CMDLINE shim for webupgrade image here
+ $(CP) $(BIN_DIR)/openwrt-$(2)-zImage $(TARGET_DIR)/zImage
+ rm -rf $(TARGET_DIR)/{var,jffs,rom}
+ $(INSTALL_DIR) $(TARGET_DIR)/var
+ $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img
endef
define Build/Compile
@@ -51,13 +61,15 @@ endef
define Image/Build/jffs2-128k
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
- $(call Image/Build/slug,$(1))
+ $(call Image/Build/Linksys,$(1))
+ $(call Image/Build/Freecom,$(1),fsg3,$(1))
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
- $(call Image/Build/slug,$(1))
+ $(call Image/Build/Linksys,$(1),nslu2,$(1))
+ $(call Image/Build/Freecom,$(1),fsg3,$(1))
endef
$(eval $(call BuildImage))