summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-23 18:14:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-23 18:14:14 +0000
commite05f4e46d9ecb19e60e39fe32c3e5d064da78b08 (patch)
tree27f3850a2528d0ae5216a36cda3bd5934e60fb88 /target/linux/ixp4xx/image
parent03205ec7407b379602abd8bb0c41c62fe28151f4 (diff)
downloadmaster-31e0f0ae-e05f4e46d9ecb19e60e39fe32c3e5d064da78b08.tar.gz
master-31e0f0ae-e05f4e46d9ecb19e60e39fe32c3e5d064da78b08.tar.bz2
master-31e0f0ae-e05f4e46d9ecb19e60e39fe32c3e5d064da78b08.zip
do not use --owner=root or --group=root when running tar. it does not work on systems that name their root group differently
SVN-Revision: 14995
Diffstat (limited to 'target/linux/ixp4xx/image')
-rw-r--r--target/linux/ixp4xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 2fec61b239..53d2ef0f63 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -26,7 +26,7 @@ define Image/Build/Freecom
$(CP) $(BIN_DIR)/openwrt-$(2)-zImage $(TARGET_DIR)/zImage
rm -rf $(TARGET_DIR)/{var,jffs,rom}
$(INSTALL_DIR) $(TARGET_DIR)/var
- $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
$(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img
endef