summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/harddisk
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-12-07 22:30:56 +0000
committerRod Whitby <rod@whitby.id.au>2007-12-07 22:30:56 +0000
commit06b6aaae20631ee3054f26a8571a0cfc83841ce1 (patch)
treeac18e0cbdd974c0530c3c4cc0e746d4586533eda /target/linux/ixp4xx/harddisk
parent610fcbfd85d83accda5ce69e12b343b4a49da11e (diff)
downloadmaster-31e0f0ae-06b6aaae20631ee3054f26a8571a0cfc83841ce1.tar.gz
master-31e0f0ae-06b6aaae20631ee3054f26a8571a0cfc83841ce1.tar.bz2
master-31e0f0ae-06b6aaae20631ee3054f26a8571a0cfc83841ce1.zip
ixp4xx: Rename fsg3 subtarget to harddisk to better reflect the intention of the subtarget
SVN-Revision: 9670
Diffstat (limited to 'target/linux/ixp4xx/harddisk')
-rw-r--r--target/linux/ixp4xx/harddisk/config-default22
-rw-r--r--target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk20
-rw-r--r--target/linux/ixp4xx/harddisk/target.mk6
3 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/harddisk/config-default b/target/linux/ixp4xx/harddisk/config-default
new file mode 100644
index 0000000000..6dfaae0a8d
--- /dev/null
+++ b/target/linux/ixp4xx/harddisk/config-default
@@ -0,0 +1,22 @@
+CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
+CONFIG_ATA=y
+CONFIG_SATA_VIA=y
+CONFIG_USB_ARCH_HAS_HCD=y
+CONFIG_USB_ARCH_HAS_OHCI=y
+CONFIG_USB_ARCH_HAS_EHCI=y
+CONFIG_USB=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_SPLIT_ISO=y
+CONFIG_USB_EHCI_ROOT_HUB_TT=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_LITTLE_ENDIAN=y
+CONFIG_USB_STORAGE=y
+CONFIG_EXT3_FS=y
+CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT3_FS_POSIX_ACL=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_JBD=y
+CONFIG_FS_MBCACHE=y
+CONFIG_BLK_DEV_SD=y
+CONFIG_REISERFS_FS=y
diff --git a/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk b/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk
new file mode 100644
index 0000000000..f06fa8c66f
--- /dev/null
+++ b/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+ NAME:=Freecom FSG-3
+ PACKAGES:= \
+ kmod-madwifi wireless-tools \
+ kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-reiserfs
+endef
+
+define Profile/FSG3/Description
+ Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+
diff --git a/target/linux/ixp4xx/harddisk/target.mk b/target/linux/ixp4xx/harddisk/target.mk
new file mode 100644
index 0000000000..c71065e5f1
--- /dev/null
+++ b/target/linux/ixp4xx/harddisk/target.mk
@@ -0,0 +1,6 @@
+BOARDNAME:=Internal Hard-Disk
+
+define Target/Description
+ Build firmware images for ixp4xx based boards that boot directly from internal disk storage
+ (e.g : Freecom FSG-3, ...)
+endef