summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-01-29 20:07:41 +0000
committerJohn Crispin <john@openwrt.org>2008-01-29 20:07:41 +0000
commit0b96bf6063626538e1d646835cf19f68175baa46 (patch)
tree708b3f4b3b5332791246a28eb1cb3fdf30842135 /target/linux/ixp4xx/generic
parent9c1dfdc702baaa91e9d1bf64ca2c6f063e92b784 (diff)
downloadmaster-31e0f0ae-0b96bf6063626538e1d646835cf19f68175baa46.tar.gz
master-31e0f0ae-0b96bf6063626538e1d646835cf19f68175baa46.tar.bz2
master-31e0f0ae-0b96bf6063626538e1d646835cf19f68175baa46.zip
added new ixp4xx target
SVN-Revision: 10314
Diffstat (limited to 'target/linux/ixp4xx/generic')
-rw-r--r--target/linux/ixp4xx/generic/profiles/500-WifiAP.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk b/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk
new file mode 100644
index 0000000000..cbbca80627
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WifiAP
+ NAME:=WifiAP
+ PACKAGES:=kmod-madwifi wireless-tools \
+ kmod-scsi-core \
+ kmod-ata-core kmod-ata-artop \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3 kmod-fs-vfat gpioctl openslp hostapd wpa-supplicant
+endef
+
+define Profile/WifiAP/Description
+ Full featured image for flash based ixp4xx devices used as industrial APs
+endef
+$(eval $(call Profile,WifiAP))
+