summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-12-07 22:29:44 +0000
committerRod Whitby <rod@whitby.id.au>2007-12-07 22:29:44 +0000
commit610fcbfd85d83accda5ce69e12b343b4a49da11e (patch)
treeac1db4a62540a9b30d38b1ede774a55ca52480ba /target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
parent691be1ebe34e6658b3167fb1debf9c928d581ca1 (diff)
downloadmaster-31e0f0ae-610fcbfd85d83accda5ce69e12b343b4a49da11e.tar.gz
master-31e0f0ae-610fcbfd85d83accda5ce69e12b343b4a49da11e.tar.bz2
master-31e0f0ae-610fcbfd85d83accda5ce69e12b343b4a49da11e.zip
ixp4xx: Split into two subtargets, one normal and one for boards which boot directly from attached storage (and therefore need most kernel modules compiled in)
SVN-Revision: 9669
Diffstat (limited to 'target/linux/ixp4xx/generic/profiles/200-NSLU2.mk')
-rw-r--r--target/linux/ixp4xx/generic/profiles/200-NSLU2.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk b/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
new file mode 100644
index 0000000000..a4e1a30858
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NSLU2
+ NAME:=Linksys NSLU2
+ PACKAGES:=kmod-ixp4xx-npe \
+ kmod-scsi-core \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NSLU2/Description
+ Package set optimized for the Linksys NSLU2
+endef
+$(eval $(call Profile,NSLU2))
+