summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/ixp4xx/Makefile
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadmaster-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
master-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
master-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/ixp4xx/Makefile')
-rw-r--r--target/linux/ixp4xx/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
new file mode 100644
index 0000000000..25b60a47b7
--- /dev/null
+++ b/target/linux/ixp4xx/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=armeb
+BOARD:=ixp4xx
+BOARDNAME:=Intel XScale IXP4xx
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.21.6
+
+define Target/Description
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))