summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/profiles
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-06-29 10:47:27 +0000
committerRod Whitby <rod@whitby.id.au>2007-06-29 10:47:27 +0000
commitde21258fc8674018eb0472190362cec6c735dd02 (patch)
treef0beab900ca33497e17970bb9eee822c0fc4c68a /target/linux/ixp4xx-2.6/profiles
parent40c1d84a0fd4690dbdd6c1266fd30bc7622f61d4 (diff)
downloadmaster-31e0f0ae-de21258fc8674018eb0472190362cec6c735dd02.tar.gz
master-31e0f0ae-de21258fc8674018eb0472190362cec6c735dd02.tar.bz2
master-31e0f0ae-de21258fc8674018eb0472190362cec6c735dd02.zip
Create various profiles for consumer IXP4xx devices
SVN-Revision: 7774
Diffstat (limited to 'target/linux/ixp4xx-2.6/profiles')
-rw-r--r--target/linux/ixp4xx-2.6/profiles/100-Default.mk17
-rw-r--r--target/linux/ixp4xx-2.6/profiles/200-NSLU2.mk17
-rw-r--r--target/linux/ixp4xx-2.6/profiles/300-NAS100d.mk17
-rw-r--r--target/linux/ixp4xx-2.6/profiles/400-DSMG600RevA.mk17
4 files changed, 68 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/profiles/100-Default.mk b/target/linux/ixp4xx-2.6/profiles/100-Default.mk
new file mode 100644
index 0000000000..174267bb59
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/profiles/100-Default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=
+endef
+
+define Profile/Default/Description
+ Default IXP4xx Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/ixp4xx-2.6/profiles/200-NSLU2.mk b/target/linux/ixp4xx-2.6/profiles/200-NSLU2.mk
new file mode 100644
index 0000000000..98be5e6ef7
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/profiles/200-NSLU2.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NSLU2
+ NAME:=Linksys NSLU2
+ PACKAGES:=kmod-ixp4xx-npe kmod-usb2
+endef
+
+define Profile/NSLU2/Description
+ Package set optimized for the Linksys NSLU2
+endef
+$(eval $(call Profile,NSLU2))
+
diff --git a/target/linux/ixp4xx-2.6/profiles/300-NAS100d.mk b/target/linux/ixp4xx-2.6/profiles/300-NAS100d.mk
new file mode 100644
index 0000000000..459fd2dd03
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/profiles/300-NAS100d.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NAS100d
+ NAME:=Iomega NAS 100d
+ PACKAGES:=kmod-ixp4xx-npe kmod-pata-artop madwifi kmod-usb2
+endef
+
+define Profile/NAS100d/Description
+ Package set optimized for the Iomega NAS 100d
+endef
+$(eval $(call Profile,NAS100d))
+
diff --git a/target/linux/ixp4xx-2.6/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx-2.6/profiles/400-DSMG600RevA.mk
new file mode 100644
index 0000000000..e16ed0c48a
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/profiles/400-DSMG600RevA.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DSMG600RevA
+ NAME:=DSM-G600 Rev A
+ PACKAGES:=kmod-via-velocity -kmod-ixp4xx-npe kmod-pata-artop madwifi kmod-usb2
+endef
+
+define Profile/DSMG600RevA/Description
+ Package set optimized for the DSM-G600 Rev A
+endef
+$(eval $(call Profile,DSMG600RevA))
+