summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image/Makefile
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-01-01 05:25:09 +0000
committerRod Whitby <rod@whitby.id.au>2007-01-01 05:25:09 +0000
commitfb8f8ffcc233b4ef4ca8baef5e9ac1ead52f9a8a (patch)
tree349b2ad2197cb27adbd78bdf5567a04961118df0 /target/linux/ixp4xx-2.6/image/Makefile
parent9052cff7c9db088a076f0adb53761541f2fa97e0 (diff)
downloadmaster-31e0f0ae-fb8f8ffcc233b4ef4ca8baef5e9ac1ead52f9a8a.tar.gz
master-31e0f0ae-fb8f8ffcc233b4ef4ca8baef5e9ac1ead52f9a8a.tar.bz2
master-31e0f0ae-fb8f8ffcc233b4ef4ca8baef5e9ac1ead52f9a8a.zip
Added the npe-ucode package to create the microcode for the IXP4XX NPE ethernet driver. Note that the user has to download the actual Intel microcode package themselves (agreeing to the Intel license to do so).
SVN-Revision: 5951
Diffstat (limited to 'target/linux/ixp4xx-2.6/image/Makefile')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index fc17c0f9ee..3c85823913 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -12,10 +12,15 @@ define Build/Compile
BUILD_DIR="$(KDIR)" \
TARGET="$(KDIR)" \
install
+ $(MAKE) -C npe-ucode \
+ BUILD_DIR="$(KDIR)" \
+ TARGET="$(KDIR)" \
+ install
endef
define Build/Clean
$(MAKE) -C apex clean
+ $(MAKE) -C npe-ucode clean
endef
define Image/Prepare
@@ -41,8 +46,8 @@ define Image/Build/jffs2-128k
-L $(KDIR)/apex-nslu2-armeb.bin \
-k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -m $(BIN_DIR)/NPE-B \
-p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
-# -m $(BIN_DIR)/NPE-B
endef
$(eval $(call BuildImage))