summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorPavel Kubelun <be.dissent@gmail.com>2016-06-21 11:52:52 +0200
committerJohn Crispin <john@phrozen.org>2016-06-22 19:32:06 +0200
commit9bf3ddcb2ae9cf48fba1e392ff57727f22a036bd (patch)
treee38e054f15ee36ce5daf7d32ec349c9023694cf9 /target/linux/ipq806x
parent4cd67a4f212c5a5eeeadefaf894a790853d95754 (diff)
downloadmaster-31e0f0ae-9bf3ddcb2ae9cf48fba1e392ff57727f22a036bd.tar.gz
master-31e0f0ae-9bf3ddcb2ae9cf48fba1e392ff57727f22a036bd.tar.bz2
master-31e0f0ae-9bf3ddcb2ae9cf48fba1e392ff57727f22a036bd.zip
ipq806x: move ath10k firmware selection into device profiles
Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/Makefile2
-rw-r--r--target/linux/ipq806x/image/Makefile7
2 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
index d070b05e00..0a7a7779f1 100644
--- a/target/linux/ipq806x/Makefile
+++ b/target/linux/ipq806x/Makefile
@@ -20,7 +20,7 @@ DEFAULT_PACKAGES += \
kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
- kmod-ath10k ath10k-firmware-qca99x0 wpad-mini \
+ kmod-ath10k wpad-mini \
uboot-envtools
$(eval $(call BuildTarget))
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 455ea1eb72..e039df7822 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -107,6 +107,7 @@ define Device/AP148
PAGESIZE := 2048
BOARD_NAME := ap148
DEVICE_TITLE := Qualcom AP148
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
define Device/AP148-legacy
@@ -117,6 +118,7 @@ define Device/AP148-legacy
PAGESIZE := 2048
BOARD_NAME := ap148
DEVICE_TITLE := Qualcom AP148 (legacy)
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
define Device/C2600
@@ -127,6 +129,7 @@ define Device/C2600
BOARD_NAME := c2600
TPLINK_BOARD_NAME := C2600
DEVICE_TITLE := TP-Link Archer C2600
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
define Device/D7800
@@ -139,6 +142,7 @@ define Device/D7800
PAGESIZE := 2048
BOARD_NAME := d7800
DEVICE_TITLE := Netgear Nighthawk X4 D7800
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
define Device/DB149
@@ -147,6 +151,7 @@ define Device/DB149
KERNEL_INSTALL := 1
BOARD_NAME := db149
DEVICE_TITLE := Qualcom DB149
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
define Device/EA8500
@@ -164,6 +169,7 @@ define Device/EA8500
IMAGE/sysupgrade.tar := sysupgrade-nand
DEVICE_VARS += DEVICE_DTS KERNEL_SIZE PAGESIZE BLOCKSIZE SUBPAGESIZE
DEVICE_TITLE := Linksys EA8500
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
define Device/R7500
@@ -176,6 +182,7 @@ define Device/R7500
PAGESIZE := 2048
BOARD_NAME := r7500
DEVICE_TITLE := Netgear Nighthawk X4 R7500
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500