summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-14 13:58:23 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-15 14:14:11 +0200
commit8e2764ce9bb6716acb955a0c27d8db291d68650c (patch)
tree559a52851877334a60a123410b96638719416fe2 /target/linux/ipq806x
parent7ed215437c784eb466302a5c01a4ee2fff9eac2d (diff)
downloadmaster-31e0f0ae-8e2764ce9bb6716acb955a0c27d8db291d68650c.tar.gz
master-31e0f0ae-8e2764ce9bb6716acb955a0c27d8db291d68650c.tar.bz2
master-31e0f0ae-8e2764ce9bb6716acb955a0c27d8db291d68650c.zip
image.mk: clean up redundant code related to DEVICE_DTS
It is used by a core build template, so the variable should be initialized and added to DEVICE_VARS in the core. Same for DEVICE_DTS_DIR Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 0b7c9ef9a0..f527fb648f 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -39,13 +39,12 @@ define Device/Default
PROFILES := Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
- DEVICE_DTS :=
KERNEL_PREFIX := $$(IMAGE_PREFIX)
IMAGES :=
KERNEL_IN_UBI :=
BOARD_NAME :=
endef
-DEVICE_VARS += DEVICE_DTS BOARD_NAME KERNEL_SIZE
+DEVICE_VARS += BOARD_NAME KERNEL_SIZE
define Device/LegacyImage
KERNEL_SUFFIX := -uImage
@@ -165,7 +164,6 @@ define Device/EA8500
DEVICE_TITLE := Linksys EA8500
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-DEVICE_VARS += DEVICE_DTS
define Device/R7500
$(call Device/DniImage)