summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-01-19 10:16:36 +0000
committerJohn Crispin <john@openwrt.org>2016-01-19 10:16:36 +0000
commit78a6a9aec306f3fa53b3eaffb35a2344c26a43c7 (patch)
treea805043b0b401f1cab6d549b283d3a9822cb62e7 /target/linux/ipq806x/profiles
parentf51f92d7e92633620e5300fe2e937c14c21c91bb (diff)
downloadmaster-31e0f0ae-78a6a9aec306f3fa53b3eaffb35a2344c26a43c7.tar.gz
master-31e0f0ae-78a6a9aec306f3fa53b3eaffb35a2344c26a43c7.tar.bz2
master-31e0f0ae-78a6a9aec306f3fa53b3eaffb35a2344c26a43c7.zip
ipq806x: Add support for Netgear D7800
Signed-off-by: Tathagata Das <tathagata@alumnux.com> SVN-Revision: 48360
Diffstat (limited to 'target/linux/ipq806x/profiles')
-rw-r--r--target/linux/ipq806x/profiles/netgear.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq806x/profiles/netgear.mk b/target/linux/ipq806x/profiles/netgear.mk
index 3402f45853..25258cdca3 100644
--- a/target/linux/ipq806x/profiles/netgear.mk
+++ b/target/linux/ipq806x/profiles/netgear.mk
@@ -6,6 +6,18 @@
# See /LICENSE for more information.
#
+define Profile/D7800
+ NAME:=Netgear Nighthawk X4 D7800
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
+ kmod-ath10k wpad-mini ath10k-firmware-qca99x0
+endef
+
+define Profile/D7800/Description
+ Package set for the Netgear Nighthawk X4 D7800.
+endef
+
define Profile/R7500
NAME:=Netgear Nighthawk X4 R7500
PACKAGES:= \
@@ -17,4 +29,5 @@ endef
define Profile/R7500/Description
Package set for the Netgear Nighthawk X4 R7500.
endef
+$(eval $(call Profile,D7800))
$(eval $(call Profile,R7500))