summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/profiles
diff options
context:
space:
mode:
authorRam Chandra Jangir <rjangi@codeaurora.org>2016-05-21 14:48:31 +0530
committerJohn Crispin <john@phrozen.org>2016-05-27 15:50:17 +0200
commit5e49c5795697868f6317f17fda5a2b04f299e116 (patch)
treebf6ebcc54ae88fa08f268f02a8f118939fe6bf6a /target/linux/ipq806x/profiles
parent955c341d3bec0eb4971a03924e99156367255d7b (diff)
downloadmaster-31e0f0ae-5e49c5795697868f6317f17fda5a2b04f299e116.tar.gz
master-31e0f0ae-5e49c5795697868f6317f17fda5a2b04f299e116.tar.bz2
master-31e0f0ae-5e49c5795697868f6317f17fda5a2b04f299e116.zip
ipq806x: Add support for linux-4.4
1)Changes - Rebased the patches for linux-4.4.7 - Added patch to fix spi nor fifo and dma support - Added patch to configure watchdog barktime 2)Testing Tested on IPQ AP148 Board: a. NOR boot and NAND boot b. ethernet network and ath10k wifi c. ubi sysupgrade UnTested dwc3 usb has not been validated on IPQ board(AP148) 3)Known Issues: Once we flash ubi image on AP148, and if we reset the board, uboot on first boot creates PEB and LEB for dynamic sized partitions, which is incorrect and not what linux expects which causes errors when trying to mount rootfs. In order to test this, we can use the below steps: a. Flash the ubi image on board and don't reset the board b. load the kernel fit image in RAM and boot from there. Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
Diffstat (limited to 'target/linux/ipq806x/profiles')
-rw-r--r--target/linux/ipq806x/profiles/default.mk19
-rw-r--r--target/linux/ipq806x/profiles/netgear.mk33
2 files changed, 0 insertions, 52 deletions
diff --git a/target/linux/ipq806x/profiles/default.mk b/target/linux/ipq806x/profiles/default.mk
deleted file mode 100644
index 6469bcb5f1..0000000000
--- a/target/linux/ipq806x/profiles/default.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (c) 2014 The Linux Foundation. All rights reserved.
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile (minimum package set)
- PACKAGES:= \
- kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
- kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ipq806x/profiles/netgear.mk b/target/linux/ipq806x/profiles/netgear.mk
deleted file mode 100644
index 25258cdca3..0000000000
--- a/target/linux/ipq806x/profiles/netgear.mk
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (c) 2014 The Linux Foundation. All rights reserved.
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/D7800
- NAME:=Netgear Nighthawk X4 D7800
- PACKAGES:= \
- kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
- kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
- kmod-ath10k wpad-mini ath10k-firmware-qca99x0
-endef
-
-define Profile/D7800/Description
- Package set for the Netgear Nighthawk X4 D7800.
-endef
-
-define Profile/R7500
- NAME:=Netgear Nighthawk X4 R7500
- PACKAGES:= \
- kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
- kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
- kmod-ath10k wpad-mini
-endef
-
-define Profile/R7500/Description
- Package set for the Netgear Nighthawk X4 R7500.
-endef
-$(eval $(call Profile,D7800))
-$(eval $(call Profile,R7500))