summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-08-11 16:34:08 +0200
committerJohn Crispin <john@phrozen.org>2016-08-18 09:49:18 +0200
commitd7e4b9babb6ce8bf66c4c2e721b78c30d09afdda (patch)
tree7808c469b98212bd9da8b8aa7132829946664a3c /target/linux/ipq806x/modules.mk
parent5e563262f12d919f5062b5e47d60d0be64d33d35 (diff)
downloadmaster-31e0f0ae-d7e4b9babb6ce8bf66c4c2e721b78c30d09afdda.tar.gz
master-31e0f0ae-d7e4b9babb6ce8bf66c4c2e721b78c30d09afdda.tar.bz2
master-31e0f0ae-d7e4b9babb6ce8bf66c4c2e721b78c30d09afdda.zip
ipq806x: sync with latest patches sent by QCA
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ipq806x/modules.mk')
-rw-r--r--target/linux/ipq806x/modules.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
index 04a2d4fe2c..38dd195902 100644
--- a/target/linux/ipq806x/modules.mk
+++ b/target/linux/ipq806x/modules.mk
@@ -1,6 +1,22 @@
+define KernelPackage/usb-dwc3-of-simple
+ TITLE:=DWC3 USB simple OF driver
+ DEPENDS:=+kmod-usb-dwc3
+ KCONFIG:= CONFIG_USB_DWC3_OF_SIMPLE
+ FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-of-simple.ko
+ AUTOLOAD:=$(call AutoLoad,53,dwc3-of-simple,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-dwc3-of-simple/description
+ This driver provides generic platform glue for the integrated DesignWare
+ USB3 IP Core.
+endef
+
+$(eval $(call KernelPackage,usb-dwc3-of-simple))
+
define KernelPackage/usb-phy-qcom-dwc3
TITLE:=DWC3 USB QCOM PHY driver
- DEPENDS:=@TARGET_ipq806x
+ DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
KCONFIG:= CONFIG_PHY_QCOM_DWC3
FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)