summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-03 19:06:21 +0000
committerJohn Crispin <john@openwrt.org>2015-04-03 19:06:21 +0000
commit114338003a6619582a594c4156da989e7afe102a (patch)
tree2992622e17f737b5db0acc3ccdef4c63038723e1 /target/linux/ipq806x/modules.mk
parent654312267cb8065320a2a1f0811ed7f68e260c14 (diff)
downloadmaster-31e0f0ae-114338003a6619582a594c4156da989e7afe102a.tar.gz
master-31e0f0ae-114338003a6619582a594c4156da989e7afe102a.tar.bz2
master-31e0f0ae-114338003a6619582a594c4156da989e7afe102a.zip
kernel: add package for dwc3 usb driver used on ipq806x
Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> SVN-Revision: 45260
Diffstat (limited to 'target/linux/ipq806x/modules.mk')
-rw-r--r--target/linux/ipq806x/modules.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
new file mode 100644
index 0000000000..57121bebb0
--- /dev/null
+++ b/target/linux/ipq806x/modules.mk
@@ -0,0 +1,32 @@
+define KernelPackage/usb-phy-qcom-dwc3
+ TITLE:=DWC3 USB QCOM PHY driver
+ DEPENDS:=@TARGET_ipq806x
+ KCONFIG:= CONFIG_PHY_QCOM_DWC3
+ FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
+ AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-phy-qcom-dwc3/description
+ This driver provides support for the integrated DesignWare
+ USB3 IP Core within the QCOM SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-phy-qcom-dwc3))
+
+
+define KernelPackage/usb-dwc3-qcom
+ TITLE:=DWC3 USB QCOM controller driver
+ DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3 +kmod-usb-phy-dwc3-qcom
+ KCONFIG:= CONFIG_USB_DWC3_QCOM
+ FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-qcom.ko
+ AUTOLOAD:=$(call AutoLoad,53,dwc3-qcom,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-dwc3-qcom/description
+ This driver provides support for the integrated DesignWare
+ USB3 IP Core within the QCOM SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-dwc3-qcom))