summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorAsh Benz <ash.benz@bk.ru>2016-05-27 22:26:40 +0800
committerJohn Crispin <john@phrozen.org>2016-05-27 15:50:17 +0200
commitef02e8967cac02ebec78fadd063b367e67f8fbc6 (patch)
tree434eb58cb30ce051e8a43e9cc17c67b36670d30f /target/linux/ipq806x/image
parent5e49c5795697868f6317f17fda5a2b04f299e116 (diff)
downloadmaster-31e0f0ae-ef02e8967cac02ebec78fadd063b367e67f8fbc6.tar.gz
master-31e0f0ae-ef02e8967cac02ebec78fadd063b367e67f8fbc6.tar.bz2
master-31e0f0ae-ef02e8967cac02ebec78fadd063b367e67f8fbc6.zip
ipq806x: Add Archer C2600 to image/Makefile
Signed-off-by: Ash Benz <ash.benz@bk.ru>
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile25
1 files changed, 24 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index ab3c846f1f..77391d043f 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -86,6 +86,19 @@ define Device/DniImage
endef
DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE
+define Device/TpSafeImage
+ PROFILES += $$(DEVICE_NAME)
+ FILESYSTEMS := squashfs
+ KERNEL_SUFFIX := -uImage
+ KERNEL = kernel-bin | append-dtb | uImage none
+ KERNEL_NAME := zImage
+ TPLINK_BOARD_NAME :=
+ IMAGES := factory.bin sysupgrade.bin
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+endef
+DEVICE_VARS += TPLINK_BOARD_NAME
+
define Device/AP148
$(call Device/FitImage)
$(call Device/UbiFit)
@@ -106,6 +119,16 @@ define Device/AP148-legacy
DEVICE_TITLE := Qualcom AP148 (legacy)
endef
+define Device/C2600
+ $(call Device/TpSafeImage)
+ DEVICE_DTS := qcom-ipq8064-c2600
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ BOARD_NAME := c2600
+ TPLINK_BOARD_NAME := C2600
+ DEVICE_TITLE := TP-Link Archer C2600
+endef
+
define Device/D7800
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-d7800
@@ -138,6 +161,6 @@ define Device/R7500
DEVICE_TITLE := Netgear Nighthawk X4 R7500
endef
-TARGET_DEVICES += AP148 AP148-legacy D7800 DB149 R7500
+TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 R7500
$(eval $(call BuildImage))