summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-11-04 11:33:31 +0000
committerJonas Gorski <jogo@openwrt.org>2015-11-04 11:33:31 +0000
commitd9197d8b0cf1a799a6a68283cc1c0adfd1bfa29f (patch)
tree5a279f85c2018dd0b06dc1e68da9289439fac679 /target/linux/ipq806x/image
parent008aec391a3f7813ce9584c4bd60e393825a5b3e (diff)
downloadmaster-31e0f0ae-d9197d8b0cf1a799a6a68283cc1c0adfd1bfa29f.tar.gz
master-31e0f0ae-d9197d8b0cf1a799a6a68283cc1c0adfd1bfa29f.tar.bz2
master-31e0f0ae-d9197d8b0cf1a799a6a68283cc1c0adfd1bfa29f.zip
ipq806x: fix BOARD_NAME spellings
the board names used by the upgrade check differ from the device names in case, so always set them. We can't rely on tolower or similar since different locales might have different rules for lower case letters, so set them explicitily. Fixes sysupgrade rejecting *-sysupgrade.tar because of the difference. Signed-off-by: Kaspar Schleiser <kaspar@schleiser.de> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 47381
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index c59e6d446e..14cf442f43 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -47,8 +47,9 @@ define Device/Default
KERNEL_PREFIX := $$(IMAGE_PREFIX)
IMAGES :=
KERNEL_IN_UBI :=
+ BOARD_NAME :=
endef
-DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI
+DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI BOARD_NAME
define Device/LegacyImage
KERNEL_SUFFIX := -uImage
@@ -78,12 +79,11 @@ define Device/DniImage
KERNEL_NAME := zImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
- BOARD_NAME :=
IMAGES := factory.img sysupgrade.tar
IMAGE/factory.img := append-kernel | append-ubi | netgear-dni
IMAGE/sysupgrade.tar = sysupgrade-nand
endef
-DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE BOARD_NAME
+DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE
define Device/AP148
$(call Device/FitImage)
@@ -91,6 +91,7 @@ define Device/AP148
DEVICE_DTS := qcom-ipq8064-ap148
BLOCKSIZE := 128KiB
PAGESIZE := 2048
+ BOARD_NAME := ap148
endef
define Device/AP148-legacy
@@ -99,13 +100,14 @@ define Device/AP148-legacy
DEVICE_DTS := qcom-ipq8064-ap148
BLOCKSIZE := 128KiB
PAGESIZE := 2048
- BOARD_NAME := AP148
+ BOARD_NAME := ap148
endef
define Device/DB149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
KERNEL_INSTALL := 1
+ BOARD_NAME := db149
endef
define Device/R7500