summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:00 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:00 +0000
commit89815d4645fa5d44cbfcf4ebed6e73ce11cbd040 (patch)
treeba7ffa2129ad50ed44358fc0e906359879abf649 /target/linux/ipq806x/image
parente3f6876623786d5954533c07e89fd2001557c12e (diff)
downloadmaster-31e0f0ae-89815d4645fa5d44cbfcf4ebed6e73ce11cbd040.tar.gz
master-31e0f0ae-89815d4645fa5d44cbfcf4ebed6e73ce11cbd040.tar.bz2
master-31e0f0ae-89815d4645fa5d44cbfcf4ebed6e73ce11cbd040.zip
ipq806x: build images and add sysupgrade support for AP148
Add full ubi and sysupgrade images for AP148 and add sysupgrade support for ipq806x to allow updating the current installation. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46789
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index dad6ee365e..ac0fc8450a 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -35,36 +35,50 @@ define Device/Default
DEVICE_DTS :=
KERNEL_PREFIX := $$(IMAGE_PREFIX)
IMAGES :=
+ KERNEL_IN_UBI :=
endef
-DEVICE_VARS += DEVICE_DTS
+DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI
define Device/LegacyImage
KERNEL_SUFFIX := -uImage
KERNEL = kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
- KERNEL_INSTALL := 1
endef
define Device/FitImage
KERNEL_SUFFIX := -fit-uImage.itb
KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
KERNEL_NAME := Image
- KERNEL_INSTALL := 1
+endef
+
+define Device/UbiFit
+ KERNEL_IN_UBI := 1
+ IMAGES := nand-factory.ubi nand-sysupgrade.tar
+ IMAGE/nand-factory.ubi := append-ubi
+ IMAGE/nand-sysupgrade.tar := sysupgrade-nand
endef
define Device/AP148
$(call Device/FitImage)
+ $(call Device/UbiFit)
DEVICE_DTS := qcom-ipq8064-ap148
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
endef
define Device/AP148-legacy
$(call Device/LegacyImage)
+ $(call Device/UbiFit)
DEVICE_DTS := qcom-ipq8064-ap148
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ BOARD_NAME := AP148
endef
define Device/DB149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
+ KERNEL_INSTALL := 1
endef
TARGET_DEVICES += AP148 AP148-legacy DB149