summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorPavel Kubelun <be.dissent@gmail.com>2016-06-21 11:55:00 +0200
committerJohn Crispin <john@phrozen.org>2016-06-22 19:32:06 +0200
commit823242185b56ea518568296f1a5834f736f12076 (patch)
tree098f7b028cc2733e1e4a5a3951b0a3e427935364 /target/linux/ipq806x/image
parent9bf3ddcb2ae9cf48fba1e392ff57727f22a036bd (diff)
downloadmaster-31e0f0ae-823242185b56ea518568296f1a5834f736f12076.tar.gz
master-31e0f0ae-823242185b56ea518568296f1a5834f736f12076.tar.bz2
master-31e0f0ae-823242185b56ea518568296f1a5834f736f12076.zip
ipq806x: add initial support for Netgear R7800
Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index e039df7822..43de23e1a7 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -185,6 +185,19 @@ define Device/R7500
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500
+define Device/R7800
+ $(call Device/DniImage)
+ DEVICE_DTS := qcom-ipq8064-r7800
+ KERNEL_SIZE := 2097152
+ NETGEAR_BOARD_ID := R7800
+ NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ BOARD_NAME := r7800
+ DEVICE_TITLE := Netgear Nighthawk X4S R7800
+ DEVICE_PACKAGES := ath10k-firmware-qca9984
+endef
+
+TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7800
$(eval $(call BuildImage))