summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:48 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:48 +0000
commit7a962fb55aa836c9bc6f2bdaa75e81ab8c41279c (patch)
treea8feb8422502a46ba5097bb1624e90da5b0db465 /target/linux/ipq806x/image
parent5686d67d1c407172ed904bc0d37039c080dc7961 (diff)
downloadmaster-31e0f0ae-7a962fb55aa836c9bc6f2bdaa75e81ab8c41279c.tar.gz
master-31e0f0ae-7a962fb55aa836c9bc6f2bdaa75e81ab8c41279c.tar.bz2
master-31e0f0ae-7a962fb55aa836c9bc6f2bdaa75e81ab8c41279c.zip
ipq806x: wrap legacy image in uImage
Wrap the zImage in a uImage header so we can easily boot it from legacy u-boots. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46787
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index b64d629be3..2369762ad8 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -38,8 +38,8 @@ endef
DEVICE_VARS += DEVICE_DTS
define Device/LegacyImage
- KERNEL_SUFFIX := -zImage
- KERNEL = kernel-bin | append-dtb
+ KERNEL_SUFFIX := -uImage
+ KERNEL = kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
KERNEL_INSTALL := 1
endef