summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-01-19 10:16:36 +0000
committerJohn Crispin <john@openwrt.org>2016-01-19 10:16:36 +0000
commit78a6a9aec306f3fa53b3eaffb35a2344c26a43c7 (patch)
treea805043b0b401f1cab6d549b283d3a9822cb62e7 /target/linux/ipq806x/image
parentf51f92d7e92633620e5300fe2e937c14c21c91bb (diff)
downloadmaster-31e0f0ae-78a6a9aec306f3fa53b3eaffb35a2344c26a43c7.tar.gz
master-31e0f0ae-78a6a9aec306f3fa53b3eaffb35a2344c26a43c7.tar.bz2
master-31e0f0ae-78a6a9aec306f3fa53b3eaffb35a2344c26a43c7.zip
ipq806x: Add support for Netgear D7800
Signed-off-by: Tathagata Das <tathagata@alumnux.com> SVN-Revision: 48360
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 58c4e1e872..ff8b2c7d9b 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -104,6 +104,17 @@ define Device/AP148-legacy
BOARD_NAME := ap148
endef
+define Device/D7800
+ $(call Device/DniImage)
+ DEVICE_DTS := qcom-ipq8064-d7800
+ KERNEL_SIZE := 2097152
+ NETGEAR_BOARD_ID := D7800
+ NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ BOARD_NAME := d7800
+endef
+
define Device/DB149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
@@ -122,6 +133,6 @@ define Device/R7500
BOARD_NAME := r7500
endef
-TARGET_DEVICES += AP148 AP148-legacy DB149 R7500
+TARGET_DEVICES += AP148 AP148-legacy D7800 DB149 R7500
$(eval $(call BuildImage))