summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorRam Chandra Jangir <rjangi@codeaurora.org>2016-05-21 14:48:31 +0530
committerJohn Crispin <john@phrozen.org>2016-05-27 15:50:17 +0200
commit5e49c5795697868f6317f17fda5a2b04f299e116 (patch)
treebf6ebcc54ae88fa08f268f02a8f118939fe6bf6a /target/linux/ipq806x/image
parent955c341d3bec0eb4971a03924e99156367255d7b (diff)
downloadmaster-31e0f0ae-5e49c5795697868f6317f17fda5a2b04f299e116.tar.gz
master-31e0f0ae-5e49c5795697868f6317f17fda5a2b04f299e116.tar.bz2
master-31e0f0ae-5e49c5795697868f6317f17fda5a2b04f299e116.zip
ipq806x: Add support for linux-4.4
1)Changes - Rebased the patches for linux-4.4.7 - Added patch to fix spi nor fifo and dma support - Added patch to configure watchdog barktime 2)Testing Tested on IPQ AP148 Board: a. NOR boot and NAND boot b. ethernet network and ath10k wifi c. ubi sysupgrade UnTested dwc3 usb has not been validated on IPQ board(AP148) 3)Known Issues: Once we flash ubi image on AP148, and if we reset the board, uboot on first boot creates PEB and LEB for dynamic sized partitions, which is incorrect and not what linux expects which causes errors when trying to mount rootfs. In order to test this, we can use the below steps: a. Flash the ubi image on board and don't reset the board b. load the kernel fit image in RAM and boot from there. Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index ff8b2c7d9b..ab3c846f1f 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -93,6 +93,7 @@ define Device/AP148
BLOCKSIZE := 128KiB
PAGESIZE := 2048
BOARD_NAME := ap148
+ DEVICE_TITLE := Qualcom AP148
endef
define Device/AP148-legacy
@@ -102,6 +103,7 @@ define Device/AP148-legacy
BLOCKSIZE := 128KiB
PAGESIZE := 2048
BOARD_NAME := ap148
+ DEVICE_TITLE := Qualcom AP148 (legacy)
endef
define Device/D7800
@@ -113,6 +115,7 @@ define Device/D7800
BLOCKSIZE := 128KiB
PAGESIZE := 2048
BOARD_NAME := d7800
+ DEVICE_TITLE := Netgear Nighthawk X4 D7800
endef
define Device/DB149
@@ -120,6 +123,7 @@ define Device/DB149
DEVICE_DTS := qcom-ipq8064-db149
KERNEL_INSTALL := 1
BOARD_NAME := db149
+ DEVICE_TITLE := Qualcom DB149
endef
define Device/R7500
@@ -131,6 +135,7 @@ define Device/R7500
BLOCKSIZE := 128KiB
PAGESIZE := 2048
BOARD_NAME := r7500
+ DEVICE_TITLE := Netgear Nighthawk X4 R7500
endef
TARGET_DEVICES += AP148 AP148-legacy D7800 DB149 R7500