summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
commit096b3759a98cdbbc710d8620e948eaa7ee2045ed (patch)
treeddec733630e2353a6f2890b81f65410dbfdf165c /target/linux/ipq806x/image
parent3846bb9ac92060669f9c798c3c128057a6d32809 (diff)
downloadmaster-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.gz
master-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.bz2
master-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> SVN-Revision: 46361
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index db5bf0acbc..9a1bad8fdf 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -9,7 +9,7 @@ UBINIZE_OPTS = -m 2048 -p 128KiB
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024)))
define Image/BuildKernel/FIT
- gzip -9 -c $(KDIR)/Image > $(KDIR)/Image.gz
+ gzip -9n -c $(KDIR)/Image > $(KDIR)/Image.gz
$(call CompressLzma,$(KDIR)/Image,$(KDIR)/Image.gz)
$(call Image/BuildKernel/MkFIT,$(1), $(KDIR)/Image.gz, $(LINUX_DIR)/arch/arm/boot/dts/$(1).dtb,gzip,0x42208000,0x42208000)
$(CP) $(KDIR)/fit-$(1).itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage.itb