summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-08-20 20:17:51 +0200
committerJo-Philipp Wich <jo@mein.io>2016-08-20 20:23:32 +0200
commit35be9284668d19a565d354a33febb508b0e28131 (patch)
tree3189685d2b390fdef340d7d62a9630a125b9674c /target/linux/imx6
parentc9e6b173f7477f3ff29d4c7c589f7ce5b360eeba (diff)
downloadmaster-31e0f0ae-35be9284668d19a565d354a33febb508b0e28131.tar.gz
master-31e0f0ae-35be9284668d19a565d354a33febb508b0e28131.tar.bz2
master-31e0f0ae-35be9284668d19a565d354a33febb508b0e28131.zip
imx6: fix generating bootfs in imagebuilder (FS#102)
The image builder does not bundle sub-directories within $(KERNEL_BUILD_DIR), therfore the intermediate "ventana-uImage.boot" directory is not shipped, leading to failures with "make image" later on. To circumvent the issue, store the intermediate boot files as tar archive instead of putting them into a directory to ensure that they end up in the final image builder tarball. Fixes FS#102 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 2181ea5db4..6b66376d41 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -37,10 +37,16 @@ define Build/boot-overlay
--space-fixup --force-compr=zlib --squash-uids \
$(MKUBIFS_OPTS) -c 8124 \
-o $@.boot.ubifs -d $@.boot
+
+ $(TAR) -C $@.boot -cf $@.boot.tar .
endef
define Build/bootfs.tar.gz
- $(TAR) -C $(IMAGE_KERNEL).boot \
+ rm -rf $@.boot
+ mkdir -p $@.boot
+
+ $(TAR) -C $@.boot -xf $(IMAGE_KERNEL).boot.tar
+ $(TAR) -C $@.boot \
--numeric-owner --owner=0 --group=0 --transform "s,./,./boot/," \
-czvf $@ .
endef