summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-01-11 01:28:32 +0000
committerLuka Perkov <luka@openwrt.org>2015-01-11 01:28:32 +0000
commitb78cddafcc74d83fe93057bd8623ae0701a4c93f (patch)
tree62258e8cc8f684570a6dfc9f3ee21a95a2fbf75c /target/linux/imx6
parent884a01d8a4e88d5f21a69ad555df26c0baac02bc (diff)
downloadmaster-31e0f0ae-b78cddafcc74d83fe93057bd8623ae0701a4c93f.tar.gz
master-31e0f0ae-b78cddafcc74d83fe93057bd8623ae0701a4c93f.tar.bz2
master-31e0f0ae-b78cddafcc74d83fe93057bd8623ae0701a4c93f.zip
kernel: update 3.14 to 3.14.28
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 43929
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/patches-3.14/0002-ARM-dts-added-several-new-imx-pinmux-groups.patch8
-rw-r--r--target/linux/imx6/patches-3.14/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch10
-rw-r--r--target/linux/imx6/patches-3.14/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch4
3 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/imx6/patches-3.14/0002-ARM-dts-added-several-new-imx-pinmux-groups.patch b/target/linux/imx6/patches-3.14/0002-ARM-dts-added-several-new-imx-pinmux-groups.patch
index c93662a420..f2d7f6ca17 100644
--- a/target/linux/imx6/patches-3.14/0002-ARM-dts-added-several-new-imx-pinmux-groups.patch
+++ b/target/linux/imx6/patches-3.14/0002-ARM-dts-added-several-new-imx-pinmux-groups.patch
@@ -97,10 +97,11 @@ Signed-off-by: Shawn Guo <shawn.guo@linaro.org>
};
uart4 {
-@@ -1107,6 +1158,15 @@
+@@ -1106,6 +1157,15 @@
+ >;
};
};
-
++
+ uart5 {
+ pinctrl_uart5_1: uart5grp-1 {
+ fsl,pins = <
@@ -109,7 +110,6 @@ Signed-off-by: Shawn Guo <shawn.guo@linaro.org>
+ >;
+ };
+ };
-+
+
usbotg {
pinctrl_usbotg_1: usbotggrp-1 {
- fsl,pins = <
diff --git a/target/linux/imx6/patches-3.14/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch b/target/linux/imx6/patches-3.14/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
index ab26601bfc..0bcbbd7bc3 100644
--- a/target/linux/imx6/patches-3.14/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
+++ b/target/linux/imx6/patches-3.14/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
@@ -89,7 +89,7 @@ Date: Thu May 15 12:36:23 2014 -0700
#include <linux/delay.h>
#include <linux/interrupt.h>
#include <linux/ip.h>
-@@ -2189,6 +2190,126 @@ static s32 igb_init_i2c(struct igb_adapt
+@@ -2191,6 +2192,126 @@ static s32 igb_init_i2c(struct igb_adapt
return status;
}
@@ -216,7 +216,7 @@ Date: Thu May 15 12:36:23 2014 -0700
/**
* igb_probe - Device Initialization Routine
* @pdev: PCI device information struct
-@@ -2591,6 +2712,13 @@ static int igb_probe(struct pci_dev *pde
+@@ -2593,6 +2714,13 @@ static int igb_probe(struct pci_dev *pde
}
pm_runtime_put_noidle(&pdev->dev);
@@ -230,7 +230,7 @@ Date: Thu May 15 12:36:23 2014 -0700
return 0;
err_register:
-@@ -2734,6 +2862,10 @@ static void igb_remove(struct pci_dev *p
+@@ -2736,6 +2864,10 @@ static void igb_remove(struct pci_dev *p
struct e1000_hw *hw = &adapter->hw;
pm_runtime_get_noresume(&pdev->dev);
@@ -241,7 +241,7 @@ Date: Thu May 15 12:36:23 2014 -0700
#ifdef CONFIG_IGB_HWMON
igb_sysfs_exit(adapter);
#endif
-@@ -3038,6 +3170,12 @@ static int __igb_open(struct net_device
+@@ -3040,6 +3172,12 @@ static int __igb_open(struct net_device
if (!resuming)
pm_runtime_put(&pdev->dev);
@@ -254,7 +254,7 @@ Date: Thu May 15 12:36:23 2014 -0700
/* start the watchdog. */
hw->mac.get_link_status = 1;
schedule_work(&adapter->watchdog_task);
-@@ -7093,21 +7231,41 @@ void igb_alloc_rx_buffers(struct igb_rin
+@@ -7095,21 +7233,41 @@ void igb_alloc_rx_buffers(struct igb_rin
static int igb_mii_ioctl(struct net_device *netdev, struct ifreq *ifr, int cmd)
{
struct igb_adapter *adapter = netdev_priv(netdev);
diff --git a/target/linux/imx6/patches-3.14/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch b/target/linux/imx6/patches-3.14/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch
index cf46434daa..1350d5a0bb 100644
--- a/target/linux/imx6/patches-3.14/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch
+++ b/target/linux/imx6/patches-3.14/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -278,6 +278,14 @@ endif # RTL8366_SMI
+@@ -273,6 +273,14 @@ endif # RTL8366_SMI
source "drivers/net/phy/b53/Kconfig"
@@ -17,7 +17,7 @@
config MICREL_KS8995MA
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
+@@ -39,6 +39,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_DP83640_PHY) += dp83640.o
obj-$(CONFIG_STE10XP) += ste10Xp.o
obj-$(CONFIG_MICREL_PHY) += micrel.o